Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

(Solved) Need help getting to data in a separate partition

Help for Current Versions of MX
Post Reply
User avatar
Topher
Forum Regular
Forum Regular
Posts: 814
Joined: Sun Feb 10, 2008 5:37 pm

(Solved) Need help getting to data in a separate partition

#1

Post by Topher » Wed May 29, 2019 12:20 pm

I have installed MX18.1 and have a separate partition (b7_Data) for my data files but I cannot get to them for some reason to symlink the data files to /home. I have been able to do this before but this time I can't seem to sort it out.

Thunar does not see that partition at all
Root Thunar can see the partition and the Data file and can open it and see all the data files in there.
Dolphin can see the partition and the data file but cannot open it. I can force Dolphin to open the file but then it won't open Documents, Downloads or any of the other files inside Data.
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>

#Entry for /dev/sdb8 :
UUID=bebc4d11-79b6-4b12-8546-9dd11d20d86c / ext4 defaults,noatime 1 1
#Entry for /dev/sdb7 :
UUID=998cb760-3da9-4aca-af7f-110819813b3d /mnt/b7_Data ext4 defaults,noatime 0 2
#Entry for /dev/sdb9 :
UUID=55ccf709-a07f-476f-9dd3-709eda508f76 /home ext4 defaults,noatime 1 2
#Entry for /dev/sdb5 :
UUID=3edbeeaa-1115-40cc-a93b-f888e1818021 swap swap defaults 0 0
The owner of the Data file is me so I should be able to open it. What am I not seeing and why can't Thunar see the partition?
Last edited by Topher on Wed May 29, 2019 10:35 pm, edited 1 time in total.
MX16 MoBo ASUS M4A88TD-V EVO/USB3 CPU AMD Phenom II X4 945 PSU CORSAIR CX500 (CMPSU-500CX) RAM Crucial CT2KIT25664BA1339 HD WD5000AAKX Wireless EDIMAX EW 7128g

User avatar
timkb4cq
Developer
Posts: 5148
Joined: Wed Jul 12, 2006 4:05 pm

Re: Need help getting to data in a separate partition

#2

Post by timkb4cq » Wed May 29, 2019 12:28 pm

This is what I use for my data partition. Perhaps the rw is required...

Code: Select all

UUID=5b5c115f-c47f-4da8-859a-9aafa781f43c /mnt/data auto defaults,rw,users,relatime 0 2
MSI 970A-G43 MB, AMD FX-6300 (six core), 16GB RAM, GeForce 730, Samsung 850 EVO 250GB SSD, Seagate Barracuda XT 3TB

User avatar
entropyfoe
Forum Regular
Forum Regular
Posts: 962
Joined: Thu Apr 19, 2007 11:42 am

Re: Need help getting to data in a separate partition

#3

Post by entropyfoe » Wed May 29, 2019 12:41 pm

What dies the MX Disk manager show?
Is it automounted?
Asus Prime 370X-Pro
AMD Ryzen 1600X (12 threads @ 3.6 GHz)
16 Gig DDR4 3200 (G Skill)
Nvidia -MSI GeForce GT 710 fanless
Samsung 960 NVMe SSD nvme0n1 P1-3=MX-18, P4=MX 19 beta
1TB SSD sda1= Data, 2TB WD =backups
on-board ethernet & sound

User avatar
Topher
Forum Regular
Forum Regular
Posts: 814
Joined: Sun Feb 10, 2008 5:37 pm

Re: Need help getting to data in a separate partition

#4

Post by Topher » Wed May 29, 2019 12:55 pm

Okay, I changed the fstab file and nothing seemed to change. But when I double clicked on the file Dolphin does open the file. I am not used to having to double click, so will have to change Dolphin. Maybe I didn't need to change the fstab file after all. But Thunar still does not see that partition???
However, I did symlink my data files into home and thunar is able to work as usual.
But why doesn't thunar see that partition? It does see all my other partitions that are not mounted, just not that one partition. Is there maybe a disk problem that I need to check into?
MX16 MoBo ASUS M4A88TD-V EVO/USB3 CPU AMD Phenom II X4 945 PSU CORSAIR CX500 (CMPSU-500CX) RAM Crucial CT2KIT25664BA1339 HD WD5000AAKX Wireless EDIMAX EW 7128g

User avatar
fehlix
Developer
Posts: 4942
Joined: Wed Apr 11, 2018 5:09 pm

Re: Need help getting to data in a separate partition

#5

Post by fehlix » Wed May 29, 2019 1:53 pm

Topher wrote:
Wed May 29, 2019 12:20 pm

Code: Select all

# /etc/fstab: static file system information.
#Entry for /dev/sdb7 :
UUID=998cb760-3da9-4aca-af7f-110819813b3d  /mnt/b7_Data  ext4 defaults,noatime	0  2
The owner of the Data file is me so I should be able to open it. What am I not seeing and why can't Thunar see the partition?
You might help thunar a bit to display internal fstab-mounted drives, through it's gvfs-backend. Like this:

Code: Select all

# /etc/fstab
#Entry for /dev/sdb7 :
UUID=998cb760-3da9-4aca-af7f-110819813b3d  /mnt/b7_Data  ext4  defaults,noatime,x-gvfs-show,x-gvfs-name=b7_Data  0  2
:puppy:
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

User avatar
mxer
Forum Regular
Forum Regular
Posts: 207
Joined: Fri Sep 21, 2018 9:09 am

Re: Need help getting to data in a separate partition

#6

Post by mxer » Wed May 29, 2019 2:00 pm

Thunar does not see that partition at all
Root Thunar can see the partition and the Data file and can open it and see all the data files in there.
Dolphin can see the partition and the data file but cannot open it.
Sounds to me like you don't own the mount point, check your permissions.
Maybe add users to your fstab line.
(FOSS, Linux, & BSD since 1999)

User avatar
Topher
Forum Regular
Forum Regular
Posts: 814
Joined: Sun Feb 10, 2008 5:37 pm

Re: Need help getting to data in a separate partition

#7

Post by Topher » Wed May 29, 2019 2:19 pm

mxer:
Sounds to me like you don't own the mount point, check your permissions.
Are you saying I should change the directory owner in /mnt for /b7_Data from root to me?
MX16 MoBo ASUS M4A88TD-V EVO/USB3 CPU AMD Phenom II X4 945 PSU CORSAIR CX500 (CMPSU-500CX) RAM Crucial CT2KIT25664BA1339 HD WD5000AAKX Wireless EDIMAX EW 7128g

User avatar
Topher
Forum Regular
Forum Regular
Posts: 814
Joined: Sun Feb 10, 2008 5:37 pm

Re: Need help getting to data in a separate partition

#8

Post by Topher » Wed May 29, 2019 2:27 pm

fehlix: [/quote]You might help thunar a bit to display internal fstab-mounted drives, through it's gvfs-backend. Like this:[/quote]
Thunar used to display all my partitions in MX16, now it displays all the partitions except that one. Is it because it is mounted?
MX16 MoBo ASUS M4A88TD-V EVO/USB3 CPU AMD Phenom II X4 945 PSU CORSAIR CX500 (CMPSU-500CX) RAM Crucial CT2KIT25664BA1339 HD WD5000AAKX Wireless EDIMAX EW 7128g

User avatar
fehlix
Developer
Posts: 4942
Joined: Wed Apr 11, 2018 5:09 pm

Re: Need help getting to data in a separate partition

#9

Post by fehlix » Wed May 29, 2019 2:55 pm

Topher wrote:
Wed May 29, 2019 2:27 pm
Thunar used to display all my partitions in MX16, now it displays all the partitions except that one. Is it because it is mounted?
Yes, that's what I tried to explain.
Thunar displays either unmounted partitions (not all some are "hidden") and also displays removable media partitions mounted or not. In order to have internal mounted partitions shown in Thunar other than removable media at /media you need to add those mount options
"x-gvfs-show,x-gvfs-name=Show_me_In-Thunar"
You can add further icon name to be used in Thunar like those:
x-gvfs-icon=
x-gvfs-symbolic-icon=

E.g. I have my clonezilla partition entry in fstab like this:

Code: Select all

UUID=XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX /mnt/clonezilla  ext4  defaults,noatime,x-gvfs-show,x-gvfs-name=b9_Clonezilla,x-gvfs-icon=application-vnd.oasis.opendocument.database,x-gvfs-symbolic-icon=application-vnd.oasis.opendocument.database 0  2
So my Clonezilla mounted partition shows up in Thunar as:
b9_clonezilla.png
HTH
:puppy:
You do not have the required permissions to view the files attached to this post.
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

User avatar
Topher
Forum Regular
Forum Regular
Posts: 814
Joined: Sun Feb 10, 2008 5:37 pm

Re: Need help getting to data in a separate partition

#10

Post by Topher » Wed May 29, 2019 10:20 pm

Okay, I understand. Thank you.
MX16 MoBo ASUS M4A88TD-V EVO/USB3 CPU AMD Phenom II X4 945 PSU CORSAIR CX500 (CMPSU-500CX) RAM Crucial CT2KIT25664BA1339 HD WD5000AAKX Wireless EDIMAX EW 7128g

Post Reply

Return to “MX Help”