Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Taking 3 to 4 minutes to boot during startup. Help

Help for Current Versions of MX
drbpn
Forum Novice
Forum  Novice
Posts: 8
Joined: Wed Aug 21, 2019 3:44 am

Taking 3 to 4 minutes to boot during startup. Help

#1

Post by drbpn » Thu Aug 22, 2019 12:37 am

Hello all,
I am newbie to MX. Have used ubuntu and mint for a long time on my other laptop. Been happy with it.
The current system i installed MX was a little older & ubuntu was slow on it.
I read great reviews of MX and thought it would give a new life to my system, however, it takes 3 to 4 minutes to come to startup during boot.
In addition, the clock widget shows CPU use is 100% at the start, is this okay? I have done a complete wipe of the hardware and installed however it has not helped.
I plan to use a single OS - MX, if it runs fine. I need to enter my password twice before the startup page, is this normal?
I am not good with command line, so elaborate a little if i need to work in terminal.
I have done the kernel changes as mentioned in MX linux home page and edited GRUB SVIDEO=0 as suggested in some posts and disable splash. But these have not helped really. Please guide me guys. I am attaching the output from quick system info

Code: Select all

System:    Host: Naveen Kernel: 4.19.0-5-amd64 x86_64 bits: 64 compiler: gcc v: 6.3.0 
           Desktop: Xfce 4.12.3 Distro: MX-18.3_x64 Continuum May 26  2019 
           base: Debian GNU/Linux 9 (stretch) 
Machine:   Type: Laptop System: LENOVO product: 20257 v: IdeaPad S210 Touch serial: <filter> 
           Mobo: LENOVO model: Ideapad S210 v: 31900042Windows 8 SST ROW serial: <filter> 
           UEFI: LENOVO v: 80CN13WW date: 04/10/2013 
Battery:   ID-1: BAT1 charge: 0 Wh condition: N/A model: SMP  status: Unknown 
CPU:       Topology: Dual Core model: Intel Pentium 2127U bits: 64 type: MCP arch: Ivy Bridge 
           rev: 9 L2 cache: 2048 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 7582 
           Speed: 798 MHz min/max: 800/1900 MHz Core speeds (MHz): 1: 798 2: 798 
Graphics:  Device-1: Intel 3rd Gen Core processor Graphics vendor: Lenovo driver: i915 v: kernel 
           bus ID: 00:02.0 
           Display: x11 server: X.Org 1.19.2 driver: modesetting unloaded: fbdev,vesa 
           resolution: 1366x768~60Hz 
           OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile v: 4.2 Mesa 18.2.6 
           direct render: Yes 
Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Lenovo 
           driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
           Sound Server: ALSA v: k4.19.0-5-amd64 
Network:   Device-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter vendor: Lenovo 
           driver: ath9k v: kernel port: 3040 bus ID: 02:00.0 
           IF: wlan0 state: up mac: <filter> 
           Device-2: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet vendor: Lenovo 
           driver: r8169 v: kernel port: 2000 bus ID: 03:00.0 
           IF: eth0 state: down mac: <filter> 
           Device-3: Atheros AR3012 Bluetooth 4.0 type: USB driver: btusb bus ID: 1-1.3:12 
Drives:    Local Storage: total: 465.76 GiB used: 5.34 GiB (1.1%) 
           ID-1: /dev/sda vendor: Seagate model: ST500LT012-9WS142 size: 465.76 GiB 
Partition: ID-1: / size: 100.43 GiB used: 5.17 GiB (5.1%) fs: ext4 dev: /dev/sda2 
           ID-2: /home size: 71.59 GiB used: 170.6 MiB (0.2%) fs: ext4 dev: /dev/sda3 
           ID-3: swap-1 size: 19.53 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda4 
Sensors:   System Temperatures: cpu: 47.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Repos:     Active apt repos in: /etc/apt/sources.list.d/antix.list 
           1: deb http://iso.mxrepo.com/antix/stretch stretch main
           Active apt repos in: /etc/apt/sources.list.d/debian-stable-updates.list 
           1: deb http://ftp.cn.debian.org/debian/ stretch-updates main contrib non-free
           Active apt repos in: /etc/apt/sources.list.d/debian.list 
           1: deb http://ftp.cn.debian.org/debian/ stretch main contrib non-free
           2: deb http://security.debian.org/ stretch/updates main contrib non-free
           Active apt repos in: /etc/apt/sources.list.d/mx.list 
           1: deb http://mx-pkg.mirror.net.in/MX-Linux/mx/repo/ stretch main non-free
           No active apt repos in: /etc/apt/sources.list.d/various.list 
Info:      Processes: 190 Uptime: 21m Memory: 1.76 GiB used: 865.7 MiB (47.9%) Init: SysVinit 
           runlevel: 5 Compilers: gcc: 6.3.0 Shell: bash v: 4.4.12 inxi: 3.0.33 

User avatar
asqwerth
Developer
Posts: 5168
Joined: Sun May 27, 2007 5:37 am

Re: TAKING 3 TO 4 MINUTES TO BOOT DURING STARTUP. HELP

#2

Post by asqwerth » Thu Aug 22, 2019 12:43 am

Just to check, this is install of the whole hard disk on your machine? No dual-boot?

You're not booting into MX using the grub of another distro on the same machine?
Desktop: Intel i5-4460, 16GB RAM, Intel integrated graphics
Clevo N130WU-based Ultrabook: Intel i7-8550U (Kaby Lake R), 16GB RAM, Intel integrated graphics (UEFI)
ASUS X42D laptop: AMD Phenom II, 6GB RAM, Mobility Radeon HD 5400

drbpn
Forum Novice
Forum  Novice
Posts: 8
Joined: Wed Aug 21, 2019 3:44 am

Re: TAKING 3 TO 4 MINUTES TO BOOT DURING STARTUP. HELP

#3

Post by drbpn » Thu Aug 22, 2019 2:47 am

I had dual boot before. I have deleted it and now I have a single operating system on netbook.

User avatar
Eadwine Rose
Administrator
Posts: 9372
Joined: Wed Jul 12, 2006 2:10 am

Re: Taking 3 to 4 minutes to boot during startup. Help

#4

Post by Eadwine Rose » Thu Aug 22, 2019 3:31 am

I edited your topic title, please don't shout, thank you.
MX-18.3_x64 May 26 2019 * 4.19.0-5-amd64 ext4 Xfce 4.12.3 * 8-core AMD Ryzen 7 2700
Asus TUF B450-Plus Gaming UEFI * Asus GTX 1050 Ti Nvidia 390.116 * 2x16Gb DDR4 2666 Kingston HyperX Predator
Samsung 860EVO * Samsung S24D330 & P2250 * HP Envy5030

User avatar
JayM
Qualified MX Guide
Posts: 2132
Joined: Tue Jan 08, 2019 4:47 am

Re: TAKING 3 TO 4 MINUTES TO BOOT DURING STARTUP. HELP

#5

Post by JayM » Thu Aug 22, 2019 3:42 am

First, welcome to the forum and thank you for providing your system info.

I can suggest several things to speed up booting and loading the desktop. Unfortunately some involve having to spend money:

1. I'll list this first because it doesn't cost anything: as I see you only have 2GB of RAM, using the 64-bit version of MX doesn't give you any advantages vs. the 32-bit version and I believe it runs a bit slower too.

2. Go to Settings/Session and Startup, click the Application Autostart tab, and disable anything that you don't actually use (but if in doubt leave it enabled.) For example, disable Blueman from autostarting if you never use bluetooth. Another example is samba for sharing directories and printers with Windows machines over your LAN, but the only place I know of to disable it is in the installer when you installed MX. CUPS can also be disabled there if you never plan to connect a printer.

3. Experiment with different kernels. Perhaps the 4.9 LTS kernel would perform better/faster on your machine, or perhaps one of the newer 5.1.x or 5.2.x kernels would work better.

4. (Money time): more RAM. 4GB is kind of a "sweet spot" on a 64-bit system. 8GB is even better. With only 2GB your memory is probably getting maxed out right away and Linux has to utilize your slower swap partition a lot more to emulate RAM on your hard drive.

5. (More money:) replace your hard drive with a solid-state drive. SSDs can be up to an order of magnitude faster than HDDs. Coupled with more RAM an SSD should let your computer boot in mere seconds unless there's actually something wrong with the computer itself.

I suspect the culprit is running a 64-bit OS in just 2GB of memory. While my other ideas would help speed things up too, it shouldn't take 3 to 4 minutes to boot up. 1 or 2 should be more like it at the very most, and even that's pretty slow.

Good luck!
Please read How To Ask For Help and How to Break Your System.
MX User Manual: hold down ALT and press F1. Further information may be found in the MX Wiki.

drbpn
Forum Novice
Forum  Novice
Posts: 8
Joined: Wed Aug 21, 2019 3:44 am

Re: Taking 3 to 4 minutes to boot during startup. Help

#6

Post by drbpn » Thu Aug 22, 2019 4:10 am

Thanks for the reply.
I have done the changes as suggested - removed applications which i don't use at startup.
After this it still took 3 min 30 seconds to get to start up. The ubuntu LTS OS installed on the system previously was a 64 bit as well, could boot in by 25 sec and shut down in 10 seconds.
I am thinking of changing the Kernel as suggested, but how is it done. Will this result in multiple kernels of the system which i will have to choose during startup?
I read posts about using 4.18 kernel helping the issue, however, i could not find how exactly this is done. I was not aware of 5.1x and the LTS version of kernel.
Guys guide me on how to do kernel change and is it okay to try so many kernels??
Please note: if i need to use terminal, guide me in detail. Thanks.

User avatar
JayM
Qualified MX Guide
Posts: 2132
Joined: Tue Jan 08, 2019 4:47 am

Re: Taking 3 to 4 minutes to boot during startup. Help

#7

Post by JayM » Thu Aug 22, 2019 4:23 am

Just install your chosen kernel in MX Package Installer. Afterward, run MX Tools/MX Boot Options and tic the two checkboxes:
  • Enable saving last boot choice
  • Use flat menus (no submenus)
then reboot. When the grub boot menu appears, use your arrow keys to select your preferred kernel then press enter to boot with it. Grub will "remember" your selection and use it as its default from then on unless you select a different one.

If you find a kernel that works better, it's fine to uninstall the others (although I would leave the original 4.19.05 kernel there as a back-up, just in case something happens later and you can't boot.) Kernels don't take up very much disk space so it's not a problem to have several installed at the same time.
Please read How To Ask For Help and How to Break Your System.
MX User Manual: hold down ALT and press F1. Further information may be found in the MX Wiki.

drbpn
Forum Novice
Forum  Novice
Posts: 8
Joined: Wed Aug 21, 2019 3:44 am

Re: Taking 3 to 4 minutes to boot during startup. Help

#8

Post by drbpn » Thu Aug 22, 2019 4:32 am

The option that i have in MXPI is kernel 4.15
I thought i will go back to 4.18, however it was not listed. i guess 4.15 has been released sometime ago, is it okay to try it out?? how to get kernel 4.18?
Thanks for the fast reply.

User avatar
asqwerth
Developer
Posts: 5168
Joined: Sun May 27, 2007 5:37 am

Re: Taking 3 to 4 minutes to boot during startup. Help

#9

Post by asqwerth » Thu Aug 22, 2019 4:53 am

For older machines, probably makes more sense to use the Debian Stretch default kernel of 4.9.

No point moving to even newer kernels than 4.15.


This can be found in MX Package installer >> Popular Apps tab >> Kernels
Desktop: Intel i5-4460, 16GB RAM, Intel integrated graphics
Clevo N130WU-based Ultrabook: Intel i7-8550U (Kaby Lake R), 16GB RAM, Intel integrated graphics (UEFI)
ASUS X42D laptop: AMD Phenom II, 6GB RAM, Mobility Radeon HD 5400

sunrat
Forum Regular
Forum Regular
Posts: 509
Joined: Mon Mar 28, 2016 9:54 pm

Re: Taking 3 to 4 minutes to boot during startup. Help

#10

Post by sunrat » Thu Aug 22, 2019 5:46 am

You could install and run bootchart to see what's causing the slowness. Or boot in systemd mode and run systemd-analyze.

Post Reply

Return to “MX Help”