Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

hp laserjet 1102w

Post Reply
User avatar
joaqvian
Forum Novice
Forum  Novice
Posts: 1
Joined: Fri Aug 09, 2019 7:58 pm

hp laserjet 1102w

#1

Post by joaqvian » Fri Aug 09, 2019 8:08 pm

I guys im from argentina, i ve tried this linux distro and its awesome, it runs so fast on my little thinkpad t61 core2duo with 3gb of ram.

The problem im having i cant configure my laserjet 1102 printer to work. I have visited the hplip page and follow all the instructions: download tarball, extract, cd...

and then: ./configure - make ( here it shows me "make: *** No se especificó ningún objetivo y no se encontró ningún makefile. Alto.", thus, i understand that there are

some dependencies missing, i dont know how to solve, any helpful information will be well received!

Regards for all!

User avatar
Paul..
Global Moderator
Posts: 2691
Joined: Sun Mar 18, 2007 6:34 pm

Re: hp laserjet 1102w

#2

Post by Paul.. » Fri Aug 09, 2019 8:28 pm

Try installing from the MX Package Installer (MX Tools->Package Installer->Printing->HP Printing)...should install everything you need for HPLIP

Asus Prime X470-Pro | AMD Ryzen 5 1400 (8 threads)
16 Gig DDR4 3000 | nVidia - GeForce GTX 750 Ti
Samsung 970 NVMe SSD | 860 500GB SSD

User avatar
Huckleberry
Forum Regular
Forum Regular
Posts: 589
Joined: Sat Jun 22, 2019 8:35 am

Re: hp laserjet 1102w

#3

Post by Huckleberry » Fri Aug 09, 2019 9:22 pm

As Paul said, it's easier to install HPLIP via MX Package Installer (also click the Stable Repo tab above and then search for Hplip) or Synaptic. Dependencies will be also installed by them I think.

Here it's listed as Driver Plug-in "Required" :
https://developers.hp.com/hp-linux-imaging-and-printing/supported_devices/index wrote:8 ("Required") A downloadable driver plug-in is required for printing support. ... Driver plug-ins are released under a proprietary (non-open) license and are not part of the HPLIP tarball release...
It's also downloadable here (selecting Debian) :
https://developers.hp.com/hp-linux-imag ... g/gethplip

Maybe you'd like to try also the newest (5.2.3) and the latest LTS kernel (4.9.186) in the stable repo ... (Mx Package Installer again)...
When asking for help, please first : Menu => MX Tools => Quick System Info
Even no need to select & copy. The output will get in the clipboard automatically, just paste.


MX 18.3 - 32bit 5.2.15-antix.1-686-smp-pae

User avatar
Richard
Posts: 2851
Joined: Fri Dec 12, 2008 10:31 am

Re: hp laserjet 1102w

#4

Post by Richard » Sat Aug 10, 2019 12:35 am

Just FYI,
I updated the hplip a few? weeks ago and did the required plugin update.

My HP P1102w still works fine; however,
when I start to print, a message pops up, saying that I need to install the plugin. I did reinstall the first time it popped up, but it continues.

Now I just Cancel the message and printing continues without problem. I imagine a future update will fix the erroneous message. Till then, I just cancel the message and continue printing.
LT: MX18.3: Thinkpad T430: DualCore, Intel i5-3320M, Ivy Bridge; 8GB RAM; 4.19.0-5-amd64; 119GB SSD 840PRO, Intel Graphics-Audio-Network

NB: antiX19b2full-xfce; MX18.3: AsusTek EeePC 1005HA: Intel DualCore Atom N270, 1GB RAM, 4.19.0-5-686, 150GB HDD

Post Reply

Return to “Software / Configuration”