The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

HELP troubleshoot backing up user files to ext. medium

Help on MX KDE Re-spins
Post Reply
User avatar
Forum Regular
Forum Regular
Posts: 1009
Joined: Wed Aug 02, 2006 12:12 pm

HELP troubleshoot backing up user files to ext. medium


Post by eemaestro » Sat Jun 10, 2017 3:13 pm

Today, June 10, was the first I tried backing up to my TOSHIBA EXT external 1 TB USB drive running only off USB power.

This was the first I tried since rewriting my MEPIS 12 partition w/ MX-16 about a week ago. I must have overlooked something. When I installed MX-16, I kept my user name and /home/user files intact. Everything on /home/user seemed readable and writeable up until now. I did change my user password manually after upgrading to MX-16.

My usual rsync backup script stopped working. Each and every rsync call in the backup script generates the 3-line error message

Code: Select all

sending incremental file list
rsync: mkdir "/media/TOSHIBA EXT" failed: Permission denied (13)
rsync error: error in file IO (code 11) at main.c(674) [Receiver=3.1.1]
Here are the permissions for one user text file on the external drive.

Code: Select all

$ lsf /media/jon/"TOSHIBA EXT"/URLs.txt
-rw------- 1 jon jon 259951 May 28 00:55 /media/jon/TOSHIBA EXT/URLs

Here are the permissions for my backup script.

Code: Select all

jon@mx1:~$ lsf USBackup_v
-rwxr--r-- 1 jon users 9075 Mar 16 14:12 USBackup_v*
Note I am running this script as user. In the past, it ran fine as user. However, the terminal wouldn't let me unmount (using $umount) on this VFAT external medium. I had to su everytime I wanted to manually unmount the external drive after using it. ( I never had to do this with my other identical USB drive, which is formatted ext2.)

What did I neglect to do, or overlook, in assuming my old user scripts would keep working as always after switching from MEPIS 12 to MX-16 and keeping the /home/user intact ? What did I forget to do for the new OS ? Is it the username appended to the /media mount point? i.e. /media/jon/"TOSHIBA EXT" instead of /media/"TOSHIBA EXT"/ ?

BTW, less still works fine with these files, e.g.,

Code: Select all

$less /media/jon/"TOSHIBA EXT"/URLs.txt 

Post Reply

Return to “MX KDE”