Page 1 of 2

Adobe Update?

Posted: Tue Jul 25, 2017 1:03 pm
by namida12
seems I have some troubles in Firefox? see attached...

Is there an update?

Re: Adobe Update?

Posted: Tue Jul 25, 2017 1:29 pm
by Stevo
What version do you have running? Try going here: https://get.adobe.com/flashplayer/about/

What happens if you either update flash and pepperflash in the Flash-manager,

or

install adobe-flashplugin (the preferred method now)

and restart the browser?

Re: Adobe Update?

Posted: Wed Jul 26, 2017 1:33 am
by namida12
Have an outdated one in Firefox ((26,0,0,131), and current one in google (26.0.0.137)

Code: Select all

green243@green243:~
$ inxi -F
System:    Host: green243 Kernel: 4.10.5-antix.1-amd64-smp x86_64 (64 bit) Desktop: IceWM 1.3.12+mod+20170325.1
           Distro: antiX-17.b1_x64-full keerfa 29 June 2017
Machine:   Device: laptop Mobo: MSI model: B350M GAMING PRO (MS-7A39) v: 1.0
           UEFI [Legacy]: American Megatrends v: 2.30 date: 03/24/2017
CPU:       Quad core AMD Ryzen 5 1500X (-HT-MCP-) cache: 2048 KB 
           clock speeds: max: 3500 MHz 1: 1550 MHz 2: 1550 MHz 3: 1550 MHz 4: 1550 MHz 5: 1550 MHz 6: 1550 MHz
           7: 1550 MHz 8: 1550 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RV670 [Radeon HD 3690/3850]
           Display Server: X.Org 1.19.3 drivers: ati,radeon (unloaded: modesetting,fbdev,vesa)
           Resolution: 1920x1080@60.00hz
           GLX Renderer: Gallium 0.4 on AMD RV670 (DRM 2.49.0 / 4.10.5-antix.1-amd64-smp, LLVM 3.9.1)
           GLX Version: 3.3 Mesa 13.0.6
Audio:     Card-1 Advanced Micro Devices [AMD] Device 1457 driver: snd_hda_intel
           Card-2 Advanced Micro Devices [AMD/ATI] RV670/680 HDMI Audio [Radeon HD 3690/3800 Series]
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.10.5-antix.1-amd64-smp
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
           IF: eth0 state: up speed: 1000 Mbps duplex: full mac: 30:9c:23:00:fd:16
Drives:    HDD Total Size: 250.1GB (60.4% used)
           ID-1: /dev/sda model: Samsung_SSD_850 size: 250.1GB
Partition: ID-1: / size: 14G used: 4.8G (37%) fs: ext4 dev: /dev/sda1
           ID-2: /home size: 206G used: 129G (66%) fs: ext4 dev: /dev/sda3
           ID-3: swap-1 size: 8.59GB used: 0.00GB (0%) fs: swap dev: /dev/sda2
Sensors:   System Temperatures: cpu: No active sensors found. Have you configured your sensors yet? mobo: N/A gpu: 87.0
Info:      Processes: 205 Uptime: 4:46 Memory: 969.1/16067.6MB Client: Shell (bash) inxi: 2.3.21 


Re: Adobe Update?

Posted: Wed Jul 26, 2017 10:06 am
by rokytnji.1

Code: Select all

Shockwave Flash

    File: libflashplayer.so
    Path: /usr/lib/flashplugin-nonfree/libflashplayer.so
    Version: 26.0.0.137
    State: Enabled
    Shockwave Flash 26.0 r0

Code: Select all

harry@biker:~
$ inxi -Fxz
System:    Host: biker Kernel: 4.10.1-antix.1-686-smp-pae i686 (32 bit gcc: 4.9.3) Desktop: IceWM 1.3.8
           Distro: antiX-15-V_386-full Killah P 30 June 2015
Machine:   Device: laptop System: Dell product: Latitude E4310 v: 0001
           Mobo: Dell model: 0T6M8G v: A01 BIOS: Dell v: A03 date: 07/08/2010
Battery    BAT0: charge: 44.0 Wh 111.1% condition: 39.6/44.0 Wh (90%)
           model: Samsung SDI DELL RM6618A status: Full
CPU:       Dual core Intel Core i5 M 520 (-HT-MCP-) cache: 3072 KB
           flags: (lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9576
           clock speeds: max: 2400 MHz 1: 1199 MHz 2: 1333 MHz 3: 1866 MHz 4: 1333 MHz
Graphics:  Card: Intel Core Processor Integrated Graphics Controller bus-ID: 00:02.0
           Display Server: X.Org 1.16.4 drivers: intel (unloaded: modesetting,fbdev,vesa)
           Resolution: 1366x768@60.00hz
           GLX Renderer: Mesa DRI Intel Ironlake Mobile x86/MMX/SSE2 GLX Version: 2.1 Direct Rendering: Yes
Audio:     Card Intel 5 Series/3400 Series High Definition Audio driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.10.1-antix.1-686-smp-pae
Network:   Card-1: Intel 82577LM Gigabit Network Connection driver: e1000e v: 3.2.6-k port: 6040 bus-ID: 00:19.0
           IF: eth0 state: down mac: <filter>
           Card-2: Intel Centrino Advanced-N 6200 driver: iwlwifi bus-ID: 02:00.0
           IF: wlan0 state: up mac: <filter>
Drives:    HDD Total Size: 60.0GB (47.7% used)
           ID-1: /dev/sda model: KINGSTON_SV300S3 size: 60.0GB
Partition: ID-1: / size: 7.6G used: 4.6G (64%) fs: ext3 dev: /dev/sda2
           ID-2: /home size: 48G used: 23G (50%) fs: ext3 dev: /dev/sda1
Sensors:   System Temperatures: cpu: 61.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 182 Uptime: 55 min Memory: 500.4/8026.6MB Init: SysVinit runlevel: 5 Gcc sys: 4.9.2
           Client: Shell (bash 4.3.301) inxi: 2.3.21 
harry@biker:~
$ locate libflashplayer.so
/etc/alternatives/libflashplayer.so
/home/harry/Backups/libflashplayer.so
/usr/lib/flashplugin-nonfree/libflashplayer.so
/usr/lib/mozilla/plugins/libflashplayer.so
harry@biker:~
My /usr/lib/mozzila/plugins and /etc/alternatives libflashplayer.so entries are symlinks pointing to /usr/lib/flashplugin-nonfree entry.
I download manually from adobe 1st the npapi and extract just the libflashplayer.so file to my /home/harry/Backups folder

Then open rox as root

Code: Select all

su
password then root terminal prompt shows.

Code: Select all

rox
again open another rox file manager

Code: Select all

rox
draag and drop from /home/harry/Backups folder the libflashplayer.so to /usr/lib/flashplugin-nonfree and pick copy from the menu

Then go to rox file file manager where I have /home/harry/Backups open. Then go to /etc/alternatives and //usr/lib/mozilla/plugins

Drag and drop from /usr/lib/flashplugin-nonfree/libflashplayer.so over to those other 2 folders I have open earlier.
Pick symlink relative to create my symlinks.

That way when I update adobe flashplayer manually again later on. I only need to copy my new downloaded libflashplayer.so to /usr/lib/flashplugin-nonfree to update everything. My existing symlinks I made earlier do not need to be touched.

My way works in Iceweasel/Firefox and Seamonkey. I don't use Blink browsers out side of my Chromebook. Which I also own and use from time to time.

HTH.

Re: Adobe Update?

Posted: Wed Jul 26, 2017 11:27 am
by kmathern
rokytnji.1 wrote:

Code: Select all

Shockwave Flash

    File: libflashplayer.so
    Path: /usr/lib/flashplugin-nonfree/libflashplayer.so
    Version: 26.0.0.137
    State: Enabled
    Shockwave Flash 26.0 r0

Code: Select all

harry@biker:~
$ inxi -Fxz
System:    Host: biker Kernel: 4.10.1-antix.1-686-smp-pae i686 (32 bit gcc: 4.9.3) Desktop: IceWM 1.3.8
           Distro: antiX-15-V_386-full Killah P 30 June 2015
Machine:   Device: laptop System: Dell product: Latitude E4310 v: 0001
           Mobo: Dell model: 0T6M8G v: A01 BIOS: Dell v: A03 date: 07/08/2010
Battery    BAT0: charge: 44.0 Wh 111.1% condition: 39.6/44.0 Wh (90%)
           model: Samsung SDI DELL RM6618A status: Full
CPU:       Dual core Intel Core i5 M 520 (-HT-MCP-) cache: 3072 KB
           flags: (lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9576
           clock speeds: max: 2400 MHz 1: 1199 MHz 2: 1333 MHz 3: 1866 MHz 4: 1333 MHz
Graphics:  Card: Intel Core Processor Integrated Graphics Controller bus-ID: 00:02.0
           Display Server: X.Org 1.16.4 drivers: intel (unloaded: modesetting,fbdev,vesa)
           Resolution: 1366x768@60.00hz
           GLX Renderer: Mesa DRI Intel Ironlake Mobile x86/MMX/SSE2 GLX Version: 2.1 Direct Rendering: Yes
Audio:     Card Intel 5 Series/3400 Series High Definition Audio driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.10.1-antix.1-686-smp-pae
Network:   Card-1: Intel 82577LM Gigabit Network Connection driver: e1000e v: 3.2.6-k port: 6040 bus-ID: 00:19.0
           IF: eth0 state: down mac: <filter>
           Card-2: Intel Centrino Advanced-N 6200 driver: iwlwifi bus-ID: 02:00.0
           IF: wlan0 state: up mac: <filter>
Drives:    HDD Total Size: 60.0GB (47.7% used)
           ID-1: /dev/sda model: KINGSTON_SV300S3 size: 60.0GB
Partition: ID-1: / size: 7.6G used: 4.6G (64%) fs: ext3 dev: /dev/sda2
           ID-2: /home size: 48G used: 23G (50%) fs: ext3 dev: /dev/sda1
Sensors:   System Temperatures: cpu: 61.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 182 Uptime: 55 min Memory: 500.4/8026.6MB Init: SysVinit runlevel: 5 Gcc sys: 4.9.2
           Client: Shell (bash 4.3.301) inxi: 2.3.21 
harry@biker:~
$ locate libflashplayer.so
/etc/alternatives/libflashplayer.so
/home/harry/Backups/libflashplayer.so
/usr/lib/flashplugin-nonfree/libflashplayer.so
/usr/lib/mozilla/plugins/libflashplayer.so
harry@biker:~
My /usr/lib/mozzila/plugins and /etc/alternatives libflashplayer.so entries are symlinks pointing to /usr/lib/flashplugin-nonfree entry.
I download manually from adobe 1st the npapi and extract just the libflashplayer.so file to my /home/harry/Backups folder

Then open rox as root

Code: Select all

su
password then root terminal prompt shows.

Code: Select all

rox
again open another rox file manager

Code: Select all

rox
draag and drop from /home/harry/Backups folder the libflashplayer.so to /usr/lib/flashplugin-nonfree and pick copy from the menu

Then go to rox file file manager where I have /home/harry/Backups open. Then go to /etc/alternatives and //usr/lib/mozilla/plugins

Drag and drop from /usr/lib/flashplugin-nonfree/libflashplayer.so over to those other 2 folders I have open earlier.
Pick symlink relative to create my symlinks.

That way when I update adobe flashplayer manually again later on. I only need to copy my new downloaded libflashplayer.so to /usr/lib/flashplugin-nonfree to update everything. My existing symlinks I made earlier do not need to be touched.

My way works in Iceweasel/Firefox and Seamonkey. I don't use Blink browsers out side of my Chromebook. Which I also own and use from time to time.

HTH.
I don't know if your post is aimed at MX users or antiX users, for MX users it's easier now to just install/use the adobe-flashplugin package and you should be able skip those manual steps.

I think both MX-15 and MX-16 came with flashplugin-nonfree preinstalled, but if they've upgraded to MX-16.1 (and even if they haven't) they should install adobe-flashplugin, because I don't think it gets installed automatically during the upgrades.

The MX-16.1 isos have adobe-flashplugin preinstalled by default.

And fwiw adobe-flashplugin is up-to-date at version 26.0.0.137 .

Code: Select all

$ strings /usr/lib/adobe-flashplugin/libflashplayer.so | grep LNX 
[@LNX 26,0,0,137

Re: Adobe Update?

Posted: Wed Jul 26, 2017 11:35 am
by kmathern
kmathern wrote:...And fwiw adobe-flashplugin is up-to-date at version 26.0.0.137 .

Code: Select all

$ strings /usr/lib/adobe-flashplugin/libflashplayer.so | grep LNX 
[@LNX 26,0,0,137
I now see that adobe-flashplugin is also in the antix.daveserver.info repo, but it looks like it needs to be updated to Stevo's latest.

Code: Select all

$ apt-cache policy adobe-flashplugin 
adobe-flashplugin:
  Installed: 1:20170711.1-1mx15+3
  Candidate: 1:20170711.1-1mx15+3
  Version table:
 *** 1:20170711.1-1mx15+3 0
        500 http://mxrepo.com/mx/repo/ mx15/non-free amd64 Packages
        100 /var/lib/dpkg/status
     1:20170616.1-1mx15+1 0
        500 http://antix.daveserver.info/jessie/ jessie/main amd64 Packages

Re: Adobe Update?

Posted: Wed Jul 26, 2017 1:45 pm
by Stevo
namida12 wrote:Have an outdated one in Firefox ((26,0,0,131), and current one in google (26.0.0.137)

Code: Select all

green243@green243:~
$ inxi -F
System:    Host: green243 Kernel: 4.10.5-antix.1-amd64-smp x86_64 (64 bit) Desktop: IceWM 1.3.12+mod+20170325.1
           Distro: antiX-17.b1_x64-full keerfa 29 June 2017
Machine:   Device: laptop Mobo: MSI model: B350M GAMING PRO (MS-7A39) v: 1.0
           UEFI [Legacy]: American Megatrends v: 2.30 date: 03/24/2017
CPU:       Quad core AMD Ryzen 5 1500X (-HT-MCP-) cache: 2048 KB 
           clock speeds: max: 3500 MHz 1: 1550 MHz 2: 1550 MHz 3: 1550 MHz 4: 1550 MHz 5: 1550 MHz 6: 1550 MHz
           7: 1550 MHz 8: 1550 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RV670 [Radeon HD 3690/3850]
           Display Server: X.Org 1.19.3 drivers: ati,radeon (unloaded: modesetting,fbdev,vesa)
           Resolution: 1920x1080@60.00hz
           GLX Renderer: Gallium 0.4 on AMD RV670 (DRM 2.49.0 / 4.10.5-antix.1-amd64-smp, LLVM 3.9.1)
           GLX Version: 3.3 Mesa 13.0.6
Audio:     Card-1 Advanced Micro Devices [AMD] Device 1457 driver: snd_hda_intel
           Card-2 Advanced Micro Devices [AMD/ATI] RV670/680 HDMI Audio [Radeon HD 3690/3800 Series]
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.10.5-antix.1-amd64-smp
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
           IF: eth0 state: up speed: 1000 Mbps duplex: full mac: 30:9c:23:00:fd:16
Drives:    HDD Total Size: 250.1GB (60.4% used)
           ID-1: /dev/sda model: Samsung_SSD_850 size: 250.1GB
Partition: ID-1: / size: 14G used: 4.8G (37%) fs: ext4 dev: /dev/sda1
           ID-2: /home size: 206G used: 129G (66%) fs: ext4 dev: /dev/sda3
           ID-3: swap-1 size: 8.59GB used: 0.00GB (0%) fs: swap dev: /dev/sda2
Sensors:   System Temperatures: cpu: No active sensors found. Have you configured your sensors yet? mobo: N/A gpu: 87.0
Info:      Processes: 205 Uptime: 4:46 Memory: 969.1/16067.6MB Client: Shell (bash) inxi: 2.3.21 

So did any of the update methods work to resolve the error message?

Re: Adobe Update?

Posted: Thu Jul 27, 2017 2:16 am
by namida12
Stevo wrote:
namida12 wrote:Have an outdated one in Firefox ((26,0,0,131), and current one in google (26.0.0.137)

So did any of the update methods work to resolve the error message?
Using the drag and drop procedure I thought I would have the latest in Firefox...

Code: Select all

green243@green243:~
$ strings /usr/lib/adobe-flashplugin/libflashplayer.so | grep LNX 
[@LNX 26,0,0,131
June 23rd version
Going to flash website: You have version 26,0,0,137 installed
https://get.adobe.com/flashplayer/about/
JR

Re: Adobe Update?

Posted: Thu Jul 27, 2017 4:33 am
by anticapitalista
latest hit antiX (stretch) repo today

Re: Adobe Update?

Posted: Thu Jul 27, 2017 2:24 pm
by rokytnji.1
I don't know if your post is aimed at MX users or antiX users, for MX users
Could be either ,or, Ken.

Edit: I guess since I mentioned rox file manager one can take my post as just AntiX specific instructions. But my way works in in my MX installs using Thunar also. I don't rely always on scripts doing installs. This is just my way of understanding our distros file system structure.

I only answered because I saw AntiX in namida12's inxi -F readout.

I know there are tools and scripts included for users if the packages are available. I just taught myself how to do things manually instead is all. Figured I'd share my method. That's all. One can use my way or ignore it. No sweat here, in the desert. :tumbleweed: