Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Cannot connect via wireless

Post Reply
User avatar
jellyjam
Forum Novice
Forum  Novice
Posts: 1
Joined: Sat Jun 15, 2019 5:23 pm

Cannot connect via wireless

#1

Post by jellyjam » Sat Jun 15, 2019 5:33 pm

First I'd like to say that I love the default color theme.

I have a laptop with Windows 10 installed, but I run a few different flavors of Linux via external SSDs. I have no trouble connecting via these systems or other LiveUSBs.

I used dd to create an antiX LiveUSB. However, when I boot and use Wicd Network Manager, the system sees the available wireless options but it cannot connect. Eventually it gives a "cannot obtain IP address" or something to that effect (I cannot cut-n-paste the error for obvious reasons).

Any hints?

User avatar
Head_on_a_Stick
Forum Regular
Forum Regular
Posts: 439
Joined: Sun Mar 17, 2019 3:37 pm

Re: Cannot connect via wireless

#2

Post by Head_on_a_Stick » Sun Jun 16, 2019 6:15 am

Check

Code: Select all

/usr/sbin/rfkill
If it shows a block under the SOFT section then use

Code: Select all

sudo /usr/sbin/rfkill unblock all
If the wireless device is unblocked then check

Code: Select all

ping -c3 8.8.8.8
ping -c3 google.com
If the first command works but the second fails then look at the output of

Code: Select all

ls -l /etc/resolv.conf
If the file is a symlink to connman then delete it and create your own instead:

Code: Select all

sudo rm /etc/resolv.conf
sudo tee /etc/resolv.conf <<!
nameserver 9.9.9.9
nameserver 2620:fe::9
!
Note: other nameservers are available.
"Individual appropriation is neither just nor serviceable. All belongs to all." — Peter Kropotkin

Post Reply

Return to “antiX”