Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

me-tv

For developer discussion on package requests
User avatar
frank392
Forum Novice
Forum  Novice
Posts: 40
Joined: Sat Jul 22, 2006 11:34 pm

me-tv

#1

Post by frank392 » Fri Mar 23, 2018 8:05 pm

Hi me-tv is not working whe you try to install it from the repos due to the lack of dependencies :
You do not have the required permissions to view the files attached to this post.

User avatar
Jerry3904
Administrator
Posts: 25743
Joined: Wed Jul 19, 2006 6:13 am

Re: me-tv

#2

Post by Jerry3904 » Fri Mar 23, 2018 8:17 pm

confirming that:

Code: Select all

$ sudo apt install me-tv -s
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 me-tv : Depends: libatkmm-1.6-1 (>= 2.22.1) but it is not installable
         Depends: libgconfmm-2.6-1c2 (>= 2.24.0) but it is not installable
         Depends: libglibmm-2.4-1c2a (>= 2.42.0) but it is not installable
         Depends: libgtkmm-2.4-1c2a (>= 1:2.24.0) but it is not installable
         Depends: libsigc++-2.0-0c2a (>= 2.2.0) but it is not installable
E: Unable to correct problems, you have held broken packages.
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, SSD 120 GB, Data 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB
Personal: XPS 13, 4.18.0-19.3-liquorix, 4 GB

User avatar
frank392
Forum Novice
Forum  Novice
Posts: 40
Joined: Sat Jul 22, 2006 11:34 pm

Re: me-tv

#3

Post by frank392 » Fri Mar 23, 2018 8:35 pm

$ sudo apt install me-tv -s
[sudo] password for frank:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
me-tv : Depends: libatkmm-1.6-1 (>= 2.22.1) but it is not installable
Depends: libgconfmm-2.6-1c2 (>= 2.24.0) but it is not installable
Depends: libglibmm-2.4-1c2a (>= 2.42.0) but it is not installable
Depends: libgtkmm-2.4-1c2a (>= 1:2.24.0) but it is not installable
Depends: libsigc++-2.0-0c2a (>= 2.2.0) but it is not installable
E: Unable to correct problems, you have held broken packages.

User avatar
Stevo
Developer
Posts: 20097
Joined: Fri Dec 15, 2006 8:07 pm

Re: me-tv

#4

Post by Stevo » Sat Mar 24, 2018 2:53 pm

Looks like the mx 15 version is in the repo somehow. What do you get for

Code: Select all

apt policy me-tv
?

User avatar
Jerry3904
Administrator
Posts: 25743
Joined: Wed Jul 19, 2006 6:13 am

Re: me-tv

#5

Post by Jerry3904 » Sat Mar 24, 2018 2:56 pm

Who? I actually have 17.1 on my production machine, and posted above on my testing laptop.
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, SSD 120 GB, Data 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB
Personal: XPS 13, 4.18.0-19.3-liquorix, 4 GB

User avatar
Stevo
Developer
Posts: 20097
Joined: Fri Dec 15, 2006 8:07 pm

Re: me-tv

#6

Post by Stevo » Sat Mar 24, 2018 3:21 pm

Me-TV was abandoned some time ago, anyway, and requires the gstreamer 0.10 framework, which was abandoned by Debian before Stretch came out. Perhaps you can use a different TV program like Kaffeine?

User avatar
Stevo
Developer
Posts: 20097
Joined: Fri Dec 15, 2006 8:07 pm

Re: me-tv

#7

Post by Stevo » Sat Mar 24, 2018 3:24 pm

Jerry3904 wrote:Who? I actually have 17.1 on my production machine, and posted above on my testing laptop.
All I get for that on 17.1 is

Code: Select all

apt-policy me-tv

Code: Select all

me-tv:
  Installed: (none)
  Candidate: 1.3.7-1mx15+1
  Version table:
     1.3.7-1mx15+1 500
        500 http://mxrepo.com/mx/repo stretch/main amd64 Packages
Which means that the MX 15 version was mistakenly uploaded to the MX 17 section. It is not possible to build a MX 17 version.

User avatar
Jerry3904
Administrator
Posts: 25743
Joined: Wed Jul 19, 2006 6:13 am

Re: me-tv

#8

Post by Jerry3904 » Sat Mar 24, 2018 3:44 pm

Stevo: I have zero interest in this! I just posted to confirm what OP put up.
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, SSD 120 GB, Data 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB
Personal: XPS 13, 4.18.0-19.3-liquorix, 4 GB

balarm
Forum Regular
Forum Regular
Posts: 122
Joined: Thu Dec 07, 2017 3:15 pm

Re: me-tv

#9

Post by balarm » Sat Mar 24, 2018 4:01 pm

@frank392
Hi, I installed Kaffeine and it works fine.
mx1 Kernel: 4.15.0-1-amd64 x86_64 bits: 64 Desktop: Xfce 4.12.3
Distro: MX-17.1_x64 Horizon December 15, 2017
Machine: Device: laptop System: LENOVO product: 1951A47 v: ThinkPad T60

User avatar
frank392
Forum Novice
Forum  Novice
Posts: 40
Joined: Sat Jul 22, 2006 11:34 pm

Re: me-tv

#10

Post by frank392 » Sat Mar 24, 2018 4:34 pm

@balam
what device are you using?
I have a Kworld usb and with me-tv works fantastic!!

on other distros

Post Reply

Return to “Package Requests / Status”