Page 1 of 1

NZ Repository problem?

Posted: Sat Dec 03, 2016 9:39 pm
by Gordon Cooper
Currently getting 404 error for three items notified e.g. http://mx.debian.nz/mx/repo/pool/main/t ... _amd64.deb 404 Not Found. Others are snapshot and smxi-inxi.

Was like this 7 hours ago, waited but no change. Anyone else with similar error?

Re: NZ Repository problem?

Posted: Sat Dec 03, 2016 9:47 pm
by timkb4cq
The current version that should be on the server is: thunderbird_45.5.1~mozillabinaries-1mx15+1_amd64.deb
Try running sudo apt-get update, or reloading in Synaptic.

Re: NZ Repository problem?

Posted: Sat Dec 03, 2016 9:57 pm
by tascoast
It's OK here for 64-bit. I did have some 404 glitches a few days ago but seemed to get over that.
My 32-bit install just updated fine.
I updated Thunderbird earlier on the 64-bit install. I'll try the Live USB 64-bit next.... :thumbup:

(I suppose all the failed translation bits are just nothing to worry about, since they have always appeared during a reload)

Re: NZ Repository problem?

Posted: Sat Dec 03, 2016 10:22 pm
by Gordon Cooper
Was still getting 404's when working thru' the notifier so downloaded them with Synaptic, probably a glitch at my end as synaptic listed extra update packages not showing through the notifier. Thanks.

Re: NZ Repository problem?

Posted: Sat Dec 03, 2016 10:30 pm
by BitJam
If one of our repos goes down, you can have you sources pointed to the next closest repo with the command:

Code: Select all

sudo localize-repo --ignore=$REPO_CODE <country-code|timezone>
The current repo codes are:

Code: Select all

ec = Ecuador
gr = Greece
la = Los Angeles, USA
nl = Netherlands
nz = New Zealand
ut = Utah, USA
tw = Taiwan
So if you are in New Zealand and you want to bypass our New Zealand repo for for now then run:

Code: Select all

sudo localize-repo --ignore nz nz
Use --hosts to see the hosts that would be used without making any changes. For example:

Code: Select all

localize-reopo --hosts --ignore=nz nz
 AX: http://ftp.yzu.edu.tw/Linux/mx-workspace/antix
 MX: http://ftp.yzu.edu.tw/Linux/mx-workspace/mx
 MP: http://ftp.yzu.edu.tw/Linux/mx-workspace/mepiscr
deb: ftp.nz.debian.org/debian
Once the repo is back up you can change back to it by omitting the --ignore parameter.

On the live system you can accomplish the same thing with the "norepo=xx" cheat. For example to avoid the New Zealand repo use "norepo=nz".

Re: NZ Repository problem?

Posted: Sun Dec 04, 2016 3:46 am
by Gordon Cooper
@ Bitjam. Thank you for that guidance. I have no problems working with repos, but have been using the Repo Manager in MX Tools to change a source. Have not really solved the original error. When the NZ server seemed to be failing, I swapped over to Taiwan and found a partially different and much smaller list of updates.
Came back to NZ and was told that over a dozen packages, already installed, were surplus and that apt-get autoremove should be used to delete them. These must/may have been picked up as dependencies for something that I had not intentionally downloaded. Something was definitely wrong but not defined, and as Tascoast, across the ditch, found no difficulties, it is probably an error on my part. All seems to be behaving now, so will wait for the next time, if it ever happens.