Page 1 of 1

ShowFoto and DigiKam Thumbnails Rotated

Posted: Wed Jun 04, 2014 9:01 am
by joany
ShowFoto 2.6.0 and DigiKam 2.6.0 both seem to have a bug that rotates some, but not all, images in the thumbnails panels. If the thumbnail of an image file is rotated in ShowFoto, the thumbnail of same image file is also rotated in DigiKam, so the same bug seems to affect both applications. However, the thumbnails in Dolphin and Imagination are not affected. Also, all images are in their proper orientations in the main window of ShowFoto -- only thumbnails panel is affected.

Is there a configuration file or files for ShowFoto and DigiKam that can be modified?

EDIT:
I figured out how to fix this. Installed exiv2 and exiftran packages. Then I ran this command on the affected image files:

Code: Select all

exiftran -a filename.jpg -o newfile.jpg
This "synchronized" the thumbnail image with the image in the ShowFoto main window. Then I rotated the image in the ShowFoto main window to the proper orientation and saved the file. Now all is good. ShowFoto and DigiKam thumbnails match the thumbnails in Dolphin and Imagination, along with the main panel of ShowFoto.

Re: ShowFoto and DigiKam Thumbnails Rotated

Posted: Wed Jun 04, 2014 12:48 pm
by joany
I now think the underlying problem is not with ShowFoto and DigiKam per se, but instead there is a discrepancy between the exif tags saved by my camera and the way KDE 4.8.4 displays thumbnail images. Thumbnails of pictures taken in landscape mode are oriented correctly, but thumbnails for pictures taken portrait mode are not rotated to the correct vertical orientation. This also causes a mismatch between the ShowFoto images in the main window and thumbnail pane for pictures taken in portrait mode. The simple fix is to execute the following command for all photo images within a directory:

Code: Select all

exiftran -ai *.*
This recursively makes auto-adjustments to the orientation based on exif tags, making the changes to each file in place. The changes only rotate the thumbnails of the camera shots taken in portrait mode.

Re: ShowFoto and DigiKam Thumbnails Rotated

Posted: Wed Jun 04, 2014 1:05 pm
by Jerry3904
I have this problem with portrait images (I shoot a lot of trees!) in Mirage on MX-14, so will look into this. Thanks.

Re: ShowFoto and DigiKam Thumbnails Rotated

Posted: Wed Jun 04, 2014 6:07 pm
by joany
The funny thing is if I take a 6x4 landscape image and crop it as a 4x6 portrait image using ShowFoto, the thumbnail image gets rotated properly as a portrait image. So it seems the problem boils down to interpreting my camera's metadata orientation tags, and maybe that's because my camera is an ancient Canon SD630. Maybe it's time for a camera upgrade. BTW, what kind of camera are you using? Also, which app are you using in MX-14/xfce to view photos?