The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Neptune OS has KDE 4.13 64-bit backported to Wheezy

Here is where all questions and discussions about KDE should go.
Post Reply
User avatar
Forum Veteran
Forum Veteran
Posts: 19576
Joined: Fri Dec 15, 2006 8:07 pm

Neptune OS has KDE 4.13 64-bit backported to Wheezy


Post by Stevo » Tue Aug 05, 2014 7:12 pm

I set up an M12-64bit in a VM and tried upgrading. The two repositories are listed here: http://neptuneos.com/en/about-neptune.html

Code: Select all

# Neptune 64Bit Sourceslist
deb http://proindi.de/zevenos/neptune/repo/ sid main

# Neptune 64Bit KDE Sourceslist
deb http://proindi.de/zevenos/neptune/kde-repo/ sid main
The Neptune package's origin is seen as "unstable", though they are backports.

Also listed is the Kanotix backport repo for LibreOffice:

Code: Select all

# Kanotix LO4 Sourceslist
deb http://kanotix.com/files/fix/lo ./
I do have the 4.13 desktop come up, though it restarted without a wallpaper or "desktop" widget. Simple to fix in the Desktop settings, though the view that shows files on the Desktop is now called "folder". Of more concern is that kdesu or the Synaptic launch command no longer work to launch programs as root--I get a terminal message about my user not being in the sudoers file. Maybe some configuration file changed...I can still start them in a root terminal, but "su -c <command>" does not work.

Don't try this with a production machine unless you have it fully backed up! I'm just playing around with it now.

I switched to the xfce4 desktop and the lightdm desktop manager to do the upgrades.

Post Reply

Return to “KDE”