Page 3 of 6

Re: Writer's font menu

Posted: Mon Aug 18, 2014 4:55 pm
by wtb
Henry:

Yes, gsfonts-X11 is installed. It seems to me that the logical answer to the mystery is that Writer does not build its font menu from the folders we have mentioned so far.

Re: Writer's font menu

Posted: Mon Aug 18, 2014 5:02 pm
by Utopia
Yes, or our Writers are differently configured? Mine is very default, as I hardly ever use it. We probably have to read some documentation to figure this out.
Henry

Re: Writer's font menu

Posted: Mon Aug 18, 2014 5:06 pm
by timkb4cq
Did you go to
Settings -> System Settings -> System Administration -> Font Installer

to see if Dingbats is disabled there?

Re: Writer's font menu

Posted: Mon Aug 18, 2014 5:20 pm
by wtb
I'm unfamiliar with the Font Installer app, but all fonts shown, including Dingbats, are checked. That checkmark suggests to me that Dingbats is enabled.

I have discovered something else. It's not just a Writer problem. I launched the Presentation module, and Dingbats is not in its font menu either. So evidently Dingbats is unavailable to the whole LO suite.

Re: Writer's font menu

Posted: Mon Aug 18, 2014 5:23 pm
by wtb
Henry:

I have not tweaked my version of Writer at all.

Re: Writer's font menu

Posted: Mon Aug 18, 2014 5:43 pm
by Utopia
So evidently Dingbats is unavailable to the whole LO suite.
Any other fonts unavailable?
Did you try disabling Dingbats and enabling it again?
It's getting late here, will continue tomorrow, if it isn't already solved by then.
Henry

Re: Writer's font menu

Posted: Mon Aug 18, 2014 6:07 pm
by wtb
Henry:

Yes, Standard Symbols also is unavailable. Thank you for your help today. I appreciate it greatly.

Bill

Re: Writer's font menu

Posted: Mon Aug 18, 2014 6:54 pm
by Siles
I am running M11, M12B2 and MX14.2 Both Dingbats and Standard Symbols work in LO Writer. I also have 77 different fonts installed including Hebrew and Arabic ones. They work but really need Abiword to display properly (right to left).

LO is fully installed and is using default settings.

Siles

Re: Writer's font menu

Posted: Tue Aug 19, 2014 3:37 am
by Utopia
Do you have something else to test those fonts that's not a part of the LibreOffice, like Inkscape?
There have been some bugs involving both Dingbats and Standard Symbols through the years. In the gsfonts-x11 package and Ghostscript. You have maybe found a new one.
Henry

Re: Writer's font menu

Posted: Tue Aug 19, 2014 5:10 am
by Utopia
Take a look at this bug report for a related problem with the gsfonts-X11 0.21 package that is used in M11:
The Symbol fonts from the URW "Standard Symbol L" and Dingbats are
listed in applications but always render standard Roman characters "ABC..."
instead of the actual symbols.
https://bugs.debian.org/cgi-bin/bugrepo ... bug=540007
They came to the the conclusion there's nothing wrong with gsfonts-X11, but "Maybe it's a problem of gsfonts".
Don't think there's much to do about it. You can test re-installing gsfonts, gsfonts-X11 and ghostscript. If that doesn't help, don't know if I can come up with any new ideas.
Henry