Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

war stories on cameras, file managers , usb etc

Post Reply
rs55
Forum Regular
Forum Regular
Posts: 288
Joined: Sun Feb 24, 2019 4:24 pm

war stories on cameras, file managers , usb etc

#1

Post by rs55 » Tue Apr 16, 2019 8:32 pm

I have become a great fan of MX Linux. It is extremely high quality - and such feats of engineering dont just happen - its a reflection of the minds behind it all. So cant thank the software engineers enough! So the following is an honest recitation of my journey - not a criticism - but hopefully of some help to others who are experiencing these issues.
From the get-go there were three things that bugged me though- usb thumb drives were behaving strangely ( I mean I dont recall worrying about usb thumb drive issues since windows 3.0 - if then). Loooong delays after files were "done" transferring - to when you could pull the darn thing out. And in a couple of instances - the file transfer actually aborting.Well, I fixed that a few weeks ago - it turns out sysctl.conf has this parameter called vm.dirty.ratio - which was set to 20%. Well I have 16 GB memory so 3.2 GB was being buffered. Anyhow, I changed this stuff- set vm.dirty.bytes to 200 MB. That fixed the annoyance. And its the same on my 8GB memory machines as a bonus(since I am not using "ratio" anymore!) !
Next was Thunar. I mean - I clicked on the icon and it took 20-30 seconds to open. Being impatient I may have clicked a few times half way through - and then after a leisurely 30 seconds - several Thunars would open. Ugly. So I switched to spacefm and have been happily using that - but it still was a lingering itch - this Thunar thing. After all the file-manager is one of the two or three top things that distinguishes a distro- right?
Well, I fixed that today:/usr/share/gvfs/mounts/network.mount , change automount to "false". That fixed the startup delay - but without that gvfs, my camera would'nt mount.
So- that takes me to the third issue - which was difficulty in mounting any of my cameras. Played around with gphoto2, gphotofs etc. Kinda worked - sometimes. Well, today I discovered gtkam - wow- wish I knew this a month or two ago. This GtKam - was specifically designed as a front end gui for gphotofs. It works - rock-solid - to mount cameras and download photos. Done.
Hope this is of some help to anyone who has struggled with these issues. Cheers.

Post Reply

Return to “General”