Page 6 of 8

Re: MX-14.1.1 "Symbiosis" bugfix/enhancements release

Posted: Thu Jun 19, 2014 4:07 pm
by Utopia
And a nice comment by linuxscreenshots:
Very clean interface. I'm a fan of the side dock position
Henry

Re: MX-14.1.1 "Symbiosis" bugfix/enhancements release

Posted: Thu Jun 19, 2014 9:40 pm
by Gordon Cooper
About the SMART HD warning.

Tried again to install on a 320 Gb WD hard drive about 5 years old. Planned to drop MX-14.1.1 into two existing partitions
reformatting them as part of the installation. Again came the warning about probable disk failure. Tried pre-formatting the
partitions with GParted to see if it made any difference, no change, still the warning. This HD has had
a lot of use and I have been prepared for bad sectors etc. but as yet none have appeared. 14.1.1 is the only
installation to have triggered the warning.

Installed 14.1.1 without any warnings or complaints onto a similar drive less than a year old.

Gordon.

Re: MX-14.1.1 "Symbiosis" bugfix/enhancements release

Posted: Thu Jun 19, 2014 9:56 pm
by Richard
Jerry3904 wrote:
Richard wrote:Put it on a USB with dd. Boots fine, runs great,
but can not connect to Broadcom wireless, OOTB:

Code: Select all

richard@mx14:/WIN/Dropbox
$ inxi -n
Network:   Card-1: Atheros AR8132 Fast Ethernet driver: atl1c
           IF: eth0 state: down mac: 00:26:22:2b:f4:05
           Card-2: Broadcom BCM4312 802.11b/g LP-PHY driver: wl
           IF: wlan0 state: up mac: 0c:60:76:54:98:82
richard@mx14:/WIN/Dropbox
Hmmm: driver is associated but no AP is recognized.
Please paste back the output of

Code: Select all

iwconfig wlan0
Can you manually associate it with AP using as root?:

Code: Select all

iwconfig wlan0 essid [name of your AP]
Thanks for the suggestion Jerry. Quoting the original post since it was about 3 pages back.
But, no joy.

Code: Select all

sudo iwconfig wlan0
wlan0    No such device
and

Code: Select all

sudo iwconfig wlan0 "Hotel Radazul 3A"
iwconfig: unknown command "Hotel Radazul 3A"
Does the same with single or no quotes.

I'll be home Saturday night and can plug it in and download the required driver: firmware-b43-lpphy-installer and run the b43-fwcutter again. That is what is installed on that AA1 notebook with MX-14.

A clarification: I ran inxi on the MX-14 installed on the netbook, which has the lpphy driver installed. Presently running MX-1411 installed on a 32GB Imation USB pen drive.
I will now boot it on an older AA1 which has no Broadcom. I'll be right back.

Back again. Connected wireless on the older AA1 as mentioned, which has no Broadcom. MX-1411 has the firmware-b43legacy-installer included.

I don't know how prevalent the firmware-b43-lpphy-installer is in netbook world.
It would be convenient to have it included, space permitting.
Otherwise, I'll just find the missing pieces and store them on Dropbox.
Thanks for your time and suggestions. My problem is re-solved. :)

Re: MX-14.1.1 "Symbiosis" bugfix/enhancements release

Posted: Thu Jun 19, 2014 10:06 pm
by fu-sen
When I installed MX-14.1.1 in a hard disk, I read warning of SMART, too.
I have not read this warning in MX-14, antiX and other distribution at all.
I do not feel the abnormality in a hard disk for the moment.

Re: MX-14.1.1 "Symbiosis" bugfix/enhancements release

Posted: Thu Jun 19, 2014 10:41 pm
by Richard
Jerry3904 wrote:
Richard wrote:Put it on a USB with dd. Boots fine, runs great,
but can not connect to Broadcom wireless, OOTB:

Code: Select all

richard@mx14:/WIN/Dropbox
$ inxi -n
Network:   Card-1: Atheros AR8132 Fast Ethernet driver: atl1c
           IF: eth0 state: down mac: 00:26:22:2b:f4:05
           Card-2: Broadcom BCM4312 802.11b/g LP-PHY driver: wl
           IF: wlan0 state: up mac: 0c:60:76:54:98:82
richard@mx14:/WIN/Dropbox
Could you run an experiment for me with that machine that does not connect OOTB using a Broadcom chipset?

1) install the experimental MX Network Assistant:

https://github.com/AdrianTM/mx-network/ ... 1_i386.deb

2) on the Troubleshooting tab, click first the Scan hardware button, then the Linux drivers button. Copy and save the output somewhere so you can post it later.

3) use the blacklist button to get rid of "wl"

4) see if you can connect now OOTB

Thanks--let me know what you find out.
@Jerry3904,
I'll do this this weekend when I get home,
where I can connect that AA1 to a wire.

Thanks.

Re: MX-14.1.1 "Symbiosis" bugfix/enhancements release

Posted: Fri Jun 20, 2014 3:18 am
by Gordon Cooper
A comment - not a criticism, I realise there's a lot of work yet to be done. Comment is that
looking with 14.1.1 at Synaptic, there seem to be files missing that were there in MX-14.
Lazarus 1.2.2 for example.

Other tests on 14.1.1 have gone well.

Gordon.

Re: MX-14.1.1 "Symbiosis" bugfix/enhancements release

Posted: Fri Jun 20, 2014 8:02 am
by m_pav
SMART attribute 187 can be ignored, it only reports an error generated by the hard disks onboard RAM memory, such errors are usually repaired in the blink of an eye and it was an unforeseen side effect of introducing a SMART data check on hard disks selected for installation. You will not see such a check in other systems as we believe we are the first to implement this type of check and we are looking into this issue to avoid unnecessary alerts in the future.

SMART attribute numbers 196, 197 and 198 with a raw value of anything more than a 0 usually indicate a failing drive and are often accompanied by SMART attribute number 5 having a value greater than 0 too.

Drives with such errors ARE failing and should not be used for anything other than paperweights.

Re: MX-14.1.1 "Symbiosis" bugfix/enhancements release

Posted: Fri Jun 20, 2014 8:15 am
by jdmeaux1952
m_pav wrote:SMART attribute 187 can be ignored, it only reports an error generated by the hard disks onboard RAM memory, such errors are usually repaired in the blink of an eye and it was an unforeseen side effect of introducing a SMART data check on hard disks selected for installation. .
That answered my question and my remarks. Thanks all around for the explanation.

Re: MX-14.1.1 "Symbiosis" bugfix/enhancements release

Posted: Fri Jun 20, 2014 8:33 am
by Adrian
I removed the check for that attribute 187 from the code, next time we rebuild MX it will not warn about it, it will warn only about real problems.

Re: MX-14.1.1 "Symbiosis" bugfix/enhancements release

Posted: Fri Jun 20, 2014 9:55 am
by Stevo
Gordon Cooper wrote:A comment - not a criticism, I realise there's a lot of work yet to be done. Comment is that
looking with 14.1.1 at Synaptic, there seem to be files missing that were there in MX-14.
Lazarus 1.2.2 for example.

Other tests on 14.1.1 have gone well.

Gordon.
Lazarus 1.2.2 is in the MEPIS 12 testing CR. Make sure that it's enabled under Repositories in Synaptic.

If the testing repo is disabled in the shipping MX 14.1.1, we should make a note of that.