Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Installation fromPXE netboot

Dbat
Forum Novice
Forum  Novice
Posts: 3
Joined: Mon Jan 25, 2016 12:23 am

Installation fromPXE netboot

#1

Post by Dbat » Mon Jan 25, 2016 12:54 am

My Notebook can not Boot over USB and has no optical drive.
So the only was to install is over PXE.
I have installed an PXE Server and try with Linux mint. All work Fine.

But with Mx-Linux Installation Hangs After a while.

Andy hints

Regards

User avatar
Eadwine Rose
Forum Veteran
Forum Veteran
Posts: 8575
Joined: Wed Jul 12, 2006 2:10 am

Re: Installation fromPXE netboot

#2

Post by Eadwine Rose » Mon Jan 25, 2016 2:00 am

Welcome Dbat! First thing to do: have you checked the md5sum of the file to see if it is correct?
MX-18.3_x64 May 26 2019 * 4.19.0-5-amd64 ext4 Xfce 4.12.3 * 8-core AMD Ryzen 7 2700
Asus TUF B450-Plus Gaming UEFI * Asus GTX 1050 Ti Nvidia 390.116 * 2x16Gb DDR4 2666 Kingston HyperX Predator
Samsung 860EVO * Samsung S24D330 & P2250 * HP Envy5030

Dbat
Forum Novice
Forum  Novice
Posts: 3
Joined: Mon Jan 25, 2016 12:23 am

Re: Installation fromPXE netboot

#3

Post by Dbat » Mon Jan 25, 2016 2:21 am

Yes the problem is how to configure the pxelinux.cfg menu

for ubuntu it's like:
KERNEL images/ubuntu/casper/vmlinuz
APPEND boot=casper vga=normal netboot=nfs nfsroot=„IP der Syno“:/volume1/PXE/images/ubuntu fetch=tftp://„IP der Syno“/images/ubuntu/casper/filesystem.squashfs initrd=images/ubuntu/casper/initrd.lz

in MXLinux you have the folders
antiX with file vmlinux
but also folder boot and EFI with subfolders

User avatar
lucky9
Forum Veteran
Forum Veteran
Posts: 11376
Joined: Wed Jul 12, 2006 5:54 am

Re: Installation fromPXE netboot

#4

Post by lucky9 » Mon Jan 25, 2016 3:36 am

no optical drive makes my suggestion somewhat lame.
Yes, even I am dishonest. Not in many ways, but in some. Forty-one, I think it is.
--Mark Twain

Dbat
Forum Novice
Forum  Novice
Posts: 3
Joined: Mon Jan 25, 2016 12:23 am

Re: Installation fromPXE netboot

#5

Post by Dbat » Mon Jan 25, 2016 5:25 am

The Problem is after load from PXE it shows following error:
unknown boot codes:
netboot=nfs

could not find linuxfs files

User avatar
i_ri
Forum Regular
Forum Regular
Posts: 358
Joined: Tue Jun 30, 2015 12:26 am

Re: Installation fromPXE netboot

#6

Post by i_ri » Mon Jan 25, 2016 8:17 am

hello
You got grub. use the success of one installed[Mint] to partition and install MX-15 then delete the first[Mint]?
install antix core or mx with this model? will that work? :
http://antix.mepis.org/index.php?title= ... ation_Tips
this begins with "for example" in the Mepis Methods documentation that so glad Jerry3904 protected.:
http://www.mepis.org/docs/en/index.php? ... thout_a_CD
tips here thread update the mepis examples too? :
http://forum.mepiscommunity.org/viewtop ... 3&start=10
encouraging that you are intent on MX; you have MX on another machine?

User avatar
lucky9
Forum Veteran
Forum Veteran
Posts: 11376
Joined: Wed Jul 12, 2006 5:54 am

Re: Installation fromPXE netboot

#7

Post by lucky9 » Mon Jan 25, 2016 3:23 pm

lucky9 wrote:no optical drive makes my suggestion somewhat lame.
But I should mention that having an External CD/DVD Burner is a benefit in many ways.
Yes, even I am dishonest. Not in many ways, but in some. Forty-one, I think it is.
--Mark Twain

User avatar
BitJam
Forum Veteran
Forum Veteran
Posts: 3341
Joined: Sat Aug 22, 2009 11:36 pm

Re: Installation fromPXE netboot

#8

Post by BitJam » Mon Jan 25, 2016 3:34 pm

Dbat wrote:The Problem is after load from PXE it shows following error:
unknown boot codes:
netboot=nfs

could not find linuxfs files
Our live system does not support the netboot feature.

I think i_ri's suggestion is excellent. If you have grub running on that machine already then you can either unpack our iso file and copy over /antiX directory and add a boot entry for it or you could try to boot our iso file directly from grub. For this to work, I think you need to pass in the fromiso=xxxx cheat pointing our system to the iso file.

I think it is better to mount the iso file and copy over the /antiX directory to your system. If you can copy the /antiX directory to the same partition that grub is on then an entry like this in your grub.cfg should work:

Code: Select all

menuentry "MX-15 Live" {
linux /antiX/vmlinuz quiet from=hd
initrd /antiX/initrd.gz
}
I don't know how this translates to the format used by the files grub-update reads. The "from=hd" is needed because we don't normally look at non-usb disk drives for the linuxfs file. You could replace this with either "blab=xxxx" or "buuid=yyyy*" where "xxxx" is the label of the partition that holds the linuxfs file or "yyyy" are the leading characters of the UUID of that partition. You can specify the entire UUID but sometimes it is easier to specify the leading characters followed by a "*".

The installer might balk at using the same drive the live system is running on. If so then, a small modification to the partition-info script can get around this restriction.
Will I cry when it's all over?
When I die will I see Heaven?

User avatar
sevo44
Forum Novice
Forum  Novice
Posts: 1
Joined: Sat Jun 08, 2019 4:53 pm

Re: Installation fromPXE netboot

#9

Post by sevo44 » Mon Jun 10, 2019 1:35 am

Prompt please, a situation with an opportunity of loading of an image on PXE changed. I get the error shown in the photo.
https://sevo44.ru/sevo44/foto-forums/mx ... ot-pxe.png

User avatar
BitJam
Forum Veteran
Forum Veteran
Posts: 3341
Joined: Sat Aug 22, 2009 11:36 pm

Re: Installation fromPXE netboot

#10

Post by BitJam » Tue Jun 11, 2019 6:15 am

sevo44 wrote:
Mon Jun 10, 2019 1:35 am
Prompt please, a situation with an opportunity of loading of an image on PXE changed. I get the error shown in the photo.
https://sevo44.ru/sevo44/foto-forums/mx ... ot-pxe.png
As I said above, our system does not support the PXE netboot feature. Sorry.
Will I cry when it's all over?
When I die will I see Heaven?

Post Reply

Return to “Installation”