Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

old grub menu after installed grub to mbr

User avatar
fehlix
Forum Veteran
Forum Veteran
Posts: 4226
Joined: Wed Apr 11, 2018 5:09 pm

Re: old grub menu after installed grub to mbr

#11

Post by fehlix » Mon Jun 10, 2019 10:01 am

cbrown wrote:
Sun Jun 09, 2019 9:41 pm
I reinstalled again, being sure to select ESP. I still get the old fedora menu. Here is the output of the suggested commands.
Let's gathering some information:
Do post text output between </> code-tags: [code] paste text here [/code].
Boot with the live USB and post "Quick System Info" (found the the Menu ).

What I'm a bit unclear is this:
cbrown wrote:
Sun Jun 09, 2019 2:41 pm
When I rebooted, I got the old fedora grub menu, and couldn't boot at all with the error:
Error: no such device
Error: unknown file system
Error: you need to load the kernel first
Because the MX18.3 installation would have cleared the content of /boot folder, I'm not clear where the fedora grub menu does come from.

Also there are a lot of 32bit efi-loader on the ESP. So the question is do you boot with 32bit or a 64bit UEFI system?
So incase it happens you boot with 32bit-UEFI, this would trigger to load BOOTIA32.EFI ,
which load -> /EFI/fedora/shimia32.efi and finally would load /EFI/fedora/grubia32.efi, the old fedora grub.

So some more question:
When you got the fedora grub menu, can you find out the UEFI-cpu version this way:
Press 'c' ( that the C for command line) and type

Code: Select all

echo  $grub_cpu  $grub_platform
Now let's try the fix the EFI-bootloader using chroot again.

When booted LiveUSB MX18.3 do open terminal again and chroot into MX18.3 with:

Code: Select all

sudo chroot-rescue-scan
First show the current UEFI NVRAM boot menu entries:

Code: Select all

efibootmgr -v
If you still have no MX entry explicitly, we could try to swap the boot entrie at position 0003 with position 0001

Code: Select all

BootOrder: 0001,0002,0003,0004,0010
...
Boot0003* UEFI OS	HD(2,GPT,622cbee9-38a3-4507-bbdd-c18b1e1ef7f6,0xc3800,0x64000)/File(\EFI\BOOT\BOOTX64.EFI)
by running:

Code: Select all

efibootmgr -o 3,2,1,4,10
Do check that \EFI\BOOT\BOOTX64.EFI is now at positions 1
with

Code: Select all

efibootmgr -v 
..
Further I would consider to clear the ESP with unused folder like fedora folder or you might even find old grub folder ..
as the ESP has limited size, so in case you have other folders than MX.. , BOOT or Microsoft,
you should get rid of those other directories.
That's it for now .. :snail:
:puppy:
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

Post Reply

Return to “Installation”