Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Failed to execute default Web Browser *SOLVED*

Post Reply
User avatar
nemo
Forum Novice
Forum  Novice
Posts: 2
Joined: Tue Nov 06, 2018 8:25 am

Failed to execute default Web Browser *SOLVED*

#1

Post by nemo » Tue Nov 06, 2018 9:03 am

I'm using MX 17.1 and use Waterfox as my web browser. Clicking on web links in emails (Thunderbird) opens Waterfox without any issues. But clicking on a link from a document results in the following error message:
Failed to execute default Web Browser.
Failed to execute child process "/opt/waterfox/waterfox" (No such file or directory).
There is a Waterfox folder in /opt but that just seems to contain an updater. Waterfox is installed in /usr/lib with a link in /usr/bin
I've looked in MIME Type editor, Alternatives Configurator and Waterfox is set as the default browser.
I assume that there must be a file/setting that needs to be changed so that the correct path is set.
Where is that please?
Last edited by nemo on Wed Nov 07, 2018 5:30 am, edited 1 time in total.

User avatar
fehlix
Developer
Posts: 4942
Joined: Wed Apr 11, 2018 5:09 pm

Re: Failed to execute default Web Browser

#2

Post by fehlix » Tue Nov 06, 2018 10:52 am

nemo wrote:
Tue Nov 06, 2018 9:03 am
Where is that please?
Settings -> Preferred Applications
If Waterfox is not listed or points to an old or invalid entry
select -> Other
and enter

Code: Select all

/usr/bin/waterfox "%s"
Welcome the the forum!
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

User avatar
Stevo
Developer
Posts: 20172
Joined: Fri Dec 15, 2006 8:07 pm

Re: Failed to execute default Web Browser

#3

Post by Stevo » Tue Nov 06, 2018 2:55 pm

How was Waterfox installed?
If you installed with the Package Installer and you're running 64-bit, can you uninstall it and install it from our test repo to see if it has the same problem?

User avatar
nemo
Forum Novice
Forum  Novice
Posts: 2
Joined: Tue Nov 06, 2018 8:25 am

Re: Failed to execute default Web Browser

#4

Post by nemo » Wed Nov 07, 2018 5:24 am

fehlix wrote:
Tue Nov 06, 2018 10:52 am
nemo wrote:
Tue Nov 06, 2018 9:03 am
Where is that please?
Settings -> Preferred Applications
If Waterfox is not listed or points to an old or invalid entry
select -> Other
and enter

Code: Select all

/usr/bin/waterfox "%s"
Welcome the the forum!
Many thanks, that did the trick.

User avatar
sunbun09
Forum Novice
Forum  Novice
Posts: 1
Joined: Thu May 30, 2019 4:17 pm

Re: Failed to execute default Web Browser *SOLVED*

#5

Post by sunbun09 » Thu May 30, 2019 4:20 pm

I was having the same issue with this thing when I ran XFCE4 on WSl on Windows 10 1903. The code that fixed my issue was simple.



First of all as a normal user type firefox in the terminal and read what the error says. If root or any other user is the owner of the home folder then proceed as following:

go sudo -s
enter your password
then in root mode type
chown [username] ~/

Thanks!

Post Reply

Return to “Desktop Environment”