Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

XFCE Terminal Window Real Estate

Post Reply
onblm
Forum Novice
Forum  Novice
Posts: 16
Joined: Mon Apr 15, 2019 8:57 am

XFCE Terminal Window Real Estate

#1

Post by onblm » Mon Aug 12, 2019 3:25 am

Good day!

Just wanted to post my inquiry here maybe somebody has encountered the same. When I open a terminal window it always has an extra space at the bottom that it does not occupy. It seems like it is reserving a space for the Terminal Menu Bar because when I show the menu bar it occupies the said space. Please look at the picture below.

https://pasteboard.co/IsjEPwB.png

Does anybody know how can I use that blank space for my terminal without showing the menu bar?

Thanks!

User avatar
JayM
Qualified MX Guide
Posts: 2143
Joined: Tue Jan 08, 2019 4:47 am

Re: XFCE Terminal Window Real Estate

#2

Post by JayM » Mon Aug 12, 2019 6:41 am

I can't see what you're talking about in your screenshot. I see the prompt at the very top of the terminal. Perhaps if you posted a screenshot of the entire terminal against a light-colored background it would be more clear as to what you mean.
Please read How To Ask For Help and How to Break Your System.
MX User Manual: hold down ALT and press F1. Further information may be found in the MX Wiki.

User avatar
rich
Developer
Posts: 323
Joined: Sat Mar 31, 2018 6:39 pm

Re: XFCE Terminal Window Real Estate

#3

Post by rich » Mon Aug 12, 2019 8:43 am

what window manager

User avatar
kmathern
Developer
Posts: 9714
Joined: Wed Jul 12, 2006 2:26 pm

Re: XFCE Terminal Window Real Estate

#4

Post by kmathern » Mon Aug 12, 2019 9:15 am

The resize handles get in the way and won't let you drag it all the way to the bottom of the screen.

Something like this works for me to get the terminal window to use the full height of the screen.

Code: Select all

xdotool getactivewindow windowsize --usehints %0 96%
The first number is for the width, it doesn't change the terminal window's width when you use %0. The second number is for the height, originally I thought you would use %100 but I found I couldn't see the prompt when it was at the bottom of the terminal window using %100, so I backed if off some. Oh, and the menubar is disabled.
Last edited by kmathern on Mon Aug 12, 2019 9:18 am, edited 1 time in total.

KoO
Forum Regular
Forum Regular
Posts: 558
Joined: Fri Feb 10, 2017 1:21 am

Re: XFCE Terminal Window Real Estate

#5

Post by KoO » Mon Aug 12, 2019 9:17 am

Right click on the terminal have a look through preferences maybe this may help you fill the bottom pixels. ?
Main : MX18.3 Debian10 (i3) , Liquorix , Intel Xeon E3-1241 v3 , 16gb , GTX970 . :linuxlove:
Lenovo T430 : Debian10 antiX17 (i3) , 4.20.12 , i5 , 12gb .
Lenovo X220 : Debian10 antiX17 (i3) , 4.19.170 , i5 , 8gb . BiosMod 1.46

User avatar
komer
Forum Novice
Forum  Novice
Posts: 71
Joined: Fri Jan 05, 2018 7:37 pm

Re: XFCE Terminal Window Real Estate

#6

Post by komer » Mon Aug 12, 2019 9:21 am

@JayM, he did that. Look below the terminal. You can see white content of web browser that is behind the terminal. Terminal is tiled to the left half of the screen.

@OP, this is due to xfce-terminal (and some other text based applications') size being restricted to multiple of text size. (i.e. if text is 9 pixels tall, terminal can be N*9 pixels tall + borders.). That's why you see gap below and right of the terminal window when it is maximized or tiled. You can't change that.

I hope they fix that in future versions of xfce4 terminal.

The way around it is to use different terminal emulator. The one whose size is not limited like that. Others can help you choose. I'm using xfce4-terminal as you do.
--komer

Post Reply

Return to “Desktop Environment”