Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Updating icon cache

Show us how you are setting up MX
Post Reply
1E1E1E
Forum Novice
Forum  Novice
Posts: 18
Joined: Sat Jan 23, 2016 3:26 pm

Updating icon cache

#1

Post by 1E1E1E » Sat Jan 23, 2016 3:41 pm

Hello,

I just installed Menda-Circle icons, but I got a warning flag telling me the icon cache needed to be updated and how to do it. So I did as I was told. I ran this command:

Code: Select all

gtk-icon-update-cache /usr/share/icons/Menda-Circle/
But I got this error message:

Code: Select all

bash: gtk-icon-update-cache: command not found
Please tell me what I'm doing wrong.
Thanks

User avatar
eugen-b
Forum Regular
Forum Regular
Posts: 572
Joined: Tue Aug 25, 2015 1:56 pm

Re: Updating icon cache

#2

Post by eugen-b » Sat Jan 23, 2016 3:45 pm

The command doesn't work and isn't of any use for SVG based icon themes, it is for PNG based themes only.
The command is BTW gtk-update-icon-cache
MX-14 on a Via Eden 1GHz CPU thin client, 3GB RAM, Via VX800 chipset, Via Chrome9 HC GPU, 32GB M.2 SSD;
btrfs with @ and @home subvolumes for MX-14;
added @antiX and @antiXhome subvolumes and copied antix 13.1 base into them, adjusting Grub from MX-14.

1E1E1E
Forum Novice
Forum  Novice
Posts: 18
Joined: Sat Jan 23, 2016 3:26 pm

Re: Updating icon cache

#3

Post by 1E1E1E » Sat Jan 23, 2016 3:51 pm

eugen-b, thanks for the information.
Should I just ignore the warning flag? Is there some to do it for svg icons? If I don't do it, will it slow my system down?

User avatar
eugen-b
Forum Regular
Forum Regular
Posts: 572
Joined: Tue Aug 25, 2015 1:56 pm

Re: Updating icon cache

#4

Post by eugen-b » Sat Jan 23, 2016 3:58 pm

You are welcome!
Just ignore the warning in Appearance settings. You might notice a difference on a CPU with 500MHz if any. Just enjoy the icons.
I will look for a link which explains the issue a little bit, I can't find it at once.
MX-14 on a Via Eden 1GHz CPU thin client, 3GB RAM, Via VX800 chipset, Via Chrome9 HC GPU, 32GB M.2 SSD;
btrfs with @ and @home subvolumes for MX-14;
added @antiX and @antiXhome subvolumes and copied antix 13.1 base into them, adjusting Grub from MX-14.

1E1E1E
Forum Novice
Forum  Novice
Posts: 18
Joined: Sat Jan 23, 2016 3:26 pm

Re: Updating icon cache

#5

Post by 1E1E1E » Sat Jan 23, 2016 4:21 pm

Thanks.
I'll keep the icons. I think my cpu can handle it.

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 25348
Joined: Wed Jul 19, 2006 6:13 am

Re: Updating icon cache

#6

Post by Jerry3904 » Sat Jan 23, 2016 4:26 pm

Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, SSD 120 GB, Data 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB
Personal: XPS 13, 4.18.0-19.3-liquorix, 4 GB

1E1E1E
Forum Novice
Forum  Novice
Posts: 18
Joined: Sat Jan 23, 2016 3:26 pm

Re: Updating icon cache

#7

Post by 1E1E1E » Sat Jan 23, 2016 5:14 pm

That was interesting.
Thanks Jerry3904

User avatar
lucky9
Forum Veteran
Forum Veteran
Posts: 11376
Joined: Wed Jul 12, 2006 5:54 am

Re: Updating icon cache

#8

Post by lucky9 » Sat Jan 23, 2016 6:59 pm

Welcome to the forum 1E1E1E! :welcome:
Yes, even I am dishonest. Not in many ways, but in some. Forty-one, I think it is.
--Mark Twain

User avatar
eugen-b
Forum Regular
Forum Regular
Posts: 572
Joined: Tue Aug 25, 2015 1:56 pm

Re: Updating icon cache

#9

Post by eugen-b » Sat Jan 23, 2016 7:08 pm

Jerry3904 wrote:Interesting explanation here:

https://bbs.archlinux.org/viewtopic.php ... 0#p1098610
That was the link I was bearing in mind, thanks!
MX-14 on a Via Eden 1GHz CPU thin client, 3GB RAM, Via VX800 chipset, Via Chrome9 HC GPU, 32GB M.2 SSD;
btrfs with @ and @home subvolumes for MX-14;
added @antiX and @antiXhome subvolumes and copied antix 13.1 base into them, adjusting Grub from MX-14.

Post Reply

Return to “Themes and Screenshots”