Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Cutecom could not start sz?

Report Bugs, Issues and non- package Requests
Post Reply
John Gay
Forum Novice
Forum  Novice
Posts: 19
Joined: Mon May 06, 2019 7:56 am

Cutecom could not start sz?

#1

Post by John Gay » Fri Jun 14, 2019 6:26 pm

I have cutecom installed on my Laptop, including lrzsz but even though I can talk to my serial device via the USB port, I cannot send any files as xmodem files. I get the error, could not start sz.
Unfortunately, cutecom seems to be the only serial terminal program that co-operates with my Boarduino.
I've tried googling this error code, but the only information I find is to install lrzsz, which I already have.
Does anyone else have any experience with cutecom, or other serial terminal programs?

Cheers,

John Gay

User avatar
JayM
Forum Guide
Forum Guide
Posts: 1395
Joined: Tue Jan 08, 2019 4:47 am

Re: Cutecom could not start sz?

#2

Post by JayM » Thu Jun 20, 2019 11:10 pm

Please run MX Tools/Quick System Info, then right-click paste into a reply. (Quick System Info automatically copies the information to the clipboard and formats it properly for the forum so all you have to do is paste it.) Thanks.
Please read How To Ask For Help and How to Break Your System.
MX User Manual: hold down ALT and press F1. Further information may be found in the MX Wiki.

John Gay
Forum Novice
Forum  Novice
Posts: 19
Joined: Mon May 06, 2019 7:56 am

Re: Cutecom could not start sz?

#3

Post by John Gay » Mon Jun 24, 2019 9:56 pm

According to
https://bugs.debian.org/cgi-bin/bugrepo ... bug=911378
This bug in Cutecom was fixed in the original source 2 years ago.
In fact the version currently available here via Debian is 0.30.1 from Dec 21 2015.
The latest version is 0.50.0 from Aug 6 2018.

I don't know where I should push to get a more up-to-date version, considering even Debian is over 3 years behind.

Sorry if I'm not approaching this correctly.

Cheers,

John Gay

Post Reply

Return to “Bugs and Non-Package Requests Forum”