Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Writer's font menu

This forum is intended for the discussion around the use of MEPIS in an office setting as distinct from home or indivicual usage. Examples include mail merge, database construction, hardware sharing, advertising, etc..
wtb
Forum Novice
Forum  Novice
Posts: 22
Joined: Sun Aug 10, 2014 7:24 am

Re: Writer's font menu

#21

Post by wtb » Mon Aug 18, 2014 4:55 pm

Henry:

Yes, gsfonts-X11 is installed. It seems to me that the logical answer to the mystery is that Writer does not build its font menu from the folders we have mentioned so far.

User avatar
Utopia
Global Moderator
Posts: 4349
Joined: Sun Apr 29, 2007 11:53 am

Re: Writer's font menu

#22

Post by Utopia » Mon Aug 18, 2014 5:02 pm

Yes, or our Writers are differently configured? Mine is very default, as I hardly ever use it. We probably have to read some documentation to figure this out.
Henry

User avatar
timkb4cq
Developer
Posts: 5145
Joined: Wed Jul 12, 2006 4:05 pm

Re: Writer's font menu

#23

Post by timkb4cq » Mon Aug 18, 2014 5:06 pm

Did you go to
Settings -> System Settings -> System Administration -> Font Installer

to see if Dingbats is disabled there?
MSI 970A-G43 MB, AMD FX-6300 (six core), 16GB RAM, GeForce 730, Samsung 850 EVO 250GB SSD, Seagate Barracuda XT 3TB

wtb
Forum Novice
Forum  Novice
Posts: 22
Joined: Sun Aug 10, 2014 7:24 am

Re: Writer's font menu

#24

Post by wtb » Mon Aug 18, 2014 5:20 pm

I'm unfamiliar with the Font Installer app, but all fonts shown, including Dingbats, are checked. That checkmark suggests to me that Dingbats is enabled.

I have discovered something else. It's not just a Writer problem. I launched the Presentation module, and Dingbats is not in its font menu either. So evidently Dingbats is unavailable to the whole LO suite.

wtb
Forum Novice
Forum  Novice
Posts: 22
Joined: Sun Aug 10, 2014 7:24 am

Re: Writer's font menu

#25

Post by wtb » Mon Aug 18, 2014 5:23 pm

Henry:

I have not tweaked my version of Writer at all.

User avatar
Utopia
Global Moderator
Posts: 4349
Joined: Sun Apr 29, 2007 11:53 am

Re: Writer's font menu

#26

Post by Utopia » Mon Aug 18, 2014 5:43 pm

So evidently Dingbats is unavailable to the whole LO suite.
Any other fonts unavailable?
Did you try disabling Dingbats and enabling it again?
It's getting late here, will continue tomorrow, if it isn't already solved by then.
Henry

wtb
Forum Novice
Forum  Novice
Posts: 22
Joined: Sun Aug 10, 2014 7:24 am

Re: Writer's font menu

#27

Post by wtb » Mon Aug 18, 2014 6:07 pm

Henry:

Yes, Standard Symbols also is unavailable. Thank you for your help today. I appreciate it greatly.

Bill

User avatar
Siles
Forum Regular
Forum Regular
Posts: 297
Joined: Wed Jul 12, 2006 2:26 am

Re: Writer's font menu

#28

Post by Siles » Mon Aug 18, 2014 6:54 pm

I am running M11, M12B2 and MX14.2 Both Dingbats and Standard Symbols work in LO Writer. I also have 77 different fonts installed including Hebrew and Arabic ones. They work but really need Abiword to display properly (right to left).

LO is fully installed and is using default settings.

Siles
Siles
Registered Mepis User 505527
Dell Precision M6400
16GB memory
MX16.1
Dell Inspiration 1720
4GB memory
MX16.1

User avatar
Utopia
Global Moderator
Posts: 4349
Joined: Sun Apr 29, 2007 11:53 am

Re: Writer's font menu

#29

Post by Utopia » Tue Aug 19, 2014 3:37 am

Do you have something else to test those fonts that's not a part of the LibreOffice, like Inkscape?
There have been some bugs involving both Dingbats and Standard Symbols through the years. In the gsfonts-x11 package and Ghostscript. You have maybe found a new one.
Henry

User avatar
Utopia
Global Moderator
Posts: 4349
Joined: Sun Apr 29, 2007 11:53 am

Re: Writer's font menu

#30

Post by Utopia » Tue Aug 19, 2014 5:10 am

Take a look at this bug report for a related problem with the gsfonts-X11 0.21 package that is used in M11:
The Symbol fonts from the URW "Standard Symbol L" and Dingbats are
listed in applications but always render standard Roman characters "ABC..."
instead of the actual symbols.
https://bugs.debian.org/cgi-bin/bugrepo ... bug=540007
They came to the the conclusion there's nothing wrong with gsfonts-X11, but "Maybe it's a problem of gsfonts".
Don't think there's much to do about it. You can test re-installing gsfonts, gsfonts-X11 and ghostscript. If that doesn't help, don't know if I can come up with any new ideas.
Henry

Post Reply

Return to “Office”