Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

OpenBox Re-spin

User avatar
manyroads
Forum Guide
Forum Guide
Posts: 1753
Joined: Sat Jun 30, 2018 6:33 pm

Re: OpenBox Re-spin

#51

Post by manyroads » Sun May 12, 2019 11:57 am

[removed by author]
see next post...
Last edited by manyroads on Mon May 13, 2019 11:04 am, edited 1 time in total.
Pax vobiscum,
Mark Rabideau - http://many-roads.com - Reg. Linux User #449130
bspwm MX-18.3 kernel: 5.1.11-antix.1-amd64-smp
"For every complex problem there is an answer that is clear, simple, and wrong." H. L. Mencken

User avatar
manyroads
Forum Guide
Forum Guide
Posts: 1753
Joined: Sat Jun 30, 2018 6:33 pm

OpenBox Re-spin (draft release)

#52

Post by manyroads » Mon May 13, 2019 11:02 am

MX Linux Openbox respin draft release

---- Update! ----

This release/ version seems to be running lighter than the previous draft versions and also a bit lighter than the version I created on antiX. The fact that it runs neck & neck with the antiX version is a HUGE surprise to me. "htop" reports ~325MB of RAM usage on my VirtualBox setup.

But when I compare the openbox resource usage (~325MB) to the 1.5 GB used by xfce4 on my main machine, openbox on MX is VERY skinny, indeed.

There are a few bugs in the release. You'll be happy to note, I do not charge extra for those. :wink: If you know of a fix or two, please send them along.

Known bug(s)- unknown solution (s) - workarounds noted where they are known
--- flatpak does not load in mxpi
--- synaptic does not start with menu selection (obmenu, jgmenu or via synapse); it only loads via terminal (cli)
--- neither of the above problems is fixed by using systemd
--- lightdm-gtk-greeter-settings, also, only runs from terminal via cli
--- "move to trash" (does not find the trash folder); Delete works fine.

Known bug(s)- known solution?? - simple work-around
-- after the install the system is not using the sardi-flat icon them... you will need to set that manually for now. Even I should be able to figure that problem out. ;)

If you have ideas on how to fix the above bugs, or others you might find, please let me know.

Screenshots:
https://ibb.co/s3MVdpG
https://ibb.co/SmcBzWS
https://ibb.co/rFwwwnQ

Download (MX Snapshot)-- this should be fully uploaded and available by 1000 (Mountain Daylight Time) 1600 (UTC) Zulu
http://treemagic.org/MX%20Desktops/MX-L ... nbox-v-0.2
Pax vobiscum,
Mark Rabideau - http://many-roads.com - Reg. Linux User #449130
bspwm MX-18.3 kernel: 5.1.11-antix.1-amd64-smp
"For every complex problem there is an answer that is clear, simple, and wrong." H. L. Mencken

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 12143
Joined: Sun Dec 16, 2007 1:17 pm

Re: OpenBox Re-spin

#53

Post by dolphin_oracle » Mon May 13, 2019 12:21 pm

I would look at your polickit authentication agent and make sure its running. its sounds to me like a lot of issues point towards a wonky policykit setup.
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-18.3
lenovo s21e - antiX-19 beta 2 (live-USB)
FYI: mx "test" repo is not the same thing as debian testing repo.

User avatar
manyroads
Forum Guide
Forum Guide
Posts: 1753
Joined: Sat Jun 30, 2018 6:33 pm

Re: OpenBox Re-spin

#54

Post by manyroads » Mon May 13, 2019 12:48 pm

dolphin_oracle wrote:
Mon May 13, 2019 12:21 pm
I would look at your polickit authentication agent and make sure its running. its sounds to me like a lot of issues point towards a wonky policykit setup.
Thank you @dolphin_oracle.... I have never worked with that. I'll give it a go. :lipsrsealed:
Pax vobiscum,
Mark Rabideau - http://many-roads.com - Reg. Linux User #449130
bspwm MX-18.3 kernel: 5.1.11-antix.1-amd64-smp
"For every complex problem there is an answer that is clear, simple, and wrong." H. L. Mencken

User avatar
manyroads
Forum Guide
Forum Guide
Posts: 1753
Joined: Sat Jun 30, 2018 6:33 pm

Re: OpenBox Re-spin

#55

Post by manyroads » Mon May 13, 2019 1:18 pm

dolphin_oracle wrote:
Mon May 13, 2019 12:21 pm
I would look at your polickit authentication agent and make sure its running. its sounds to me like a lot of issues point towards a wonky policykit setup.
Well I tried:
-- reinstalling policykit (that did nothing)...
-- copying a working set of policykit files from my home xfce machine (no joy)

I read debian instructions on policykit installations with sysVinit & shim and they didn't offer any obvious clues.
Mother google did not turn up much that looked helpful except for some things on stackexchange that mirrored the above actions. :eek:
Pax vobiscum,
Mark Rabideau - http://many-roads.com - Reg. Linux User #449130
bspwm MX-18.3 kernel: 5.1.11-antix.1-amd64-smp
"For every complex problem there is an answer that is clear, simple, and wrong." H. L. Mencken

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 12143
Joined: Sun Dec 16, 2007 1:17 pm

Re: OpenBox Re-spin

#56

Post by dolphin_oracle » Mon May 13, 2019 2:12 pm

manyroads wrote:
Mon May 13, 2019 1:18 pm
dolphin_oracle wrote:
Mon May 13, 2019 12:21 pm
I would look at your polickit authentication agent and make sure its running. its sounds to me like a lot of issues point towards a wonky policykit setup.
Well I tried:
-- reinstalling policykit (that did nothing)...
-- copying a working set of policykit files from my home xfce machine (no joy)

I read debian instructions on policykit installations with sysVinit & shim and they didn't offer any obvious clues.
Mother google did not turn up much that looked helpful except for some things on stackexchange that mirrored the above actions. :eek:
is not always enough to have policykit installed. you also need an authentication agent. we use policykit-1-gnome as the authenticator.

if your WM doesn't autostart via xdg autostart standards, then you may need to manually launch it. lxpolkit is often easier in that sort of environment, rather than policykit-1-gnome.
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-18.3
lenovo s21e - antiX-19 beta 2 (live-USB)
FYI: mx "test" repo is not the same thing as debian testing repo.

User avatar
Head_on_a_Stick
Forum Regular
Forum Regular
Posts: 486
Joined: Sun Mar 17, 2019 3:37 pm

Re: OpenBox Re-spin

#57

Post by Head_on_a_Stick » Mon May 13, 2019 3:27 pm

The OP indicates that /usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1 is listed in the openbox autostart file and so should be running.
"The state, therefore, is the most flagrant, the most cynical, and the most complete negation of humanity." — Mikhail Bakunin

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 12143
Joined: Sun Dec 16, 2007 1:17 pm

Re: OpenBox Re-spin

#58

Post by dolphin_oracle » Mon May 13, 2019 3:31 pm

Head_on_a_Stick wrote:
Mon May 13, 2019 3:27 pm
The OP indicates that /usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1 is listed in the openbox autostart file and so should be running.
I have not had success starting policykit-1-gnome that way. lxpolkit yes, but not policykit-1-gnome.
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-18.3
lenovo s21e - antiX-19 beta 2 (live-USB)
FYI: mx "test" repo is not the same thing as debian testing repo.

User avatar
Head_on_a_Stick
Forum Regular
Forum Regular
Posts: 486
Joined: Sun Mar 17, 2019 3:37 pm

Re: OpenBox Re-spin

#59

Post by Head_on_a_Stick » Mon May 13, 2019 3:44 pm

dolphin_oracle wrote:
Mon May 13, 2019 3:31 pm
I have not had success starting policykit-1-gnome that way.
It works for BunsenLabs :happy:

The OP lifted the autostart file from that distribution and it was in turn inherited from CrunchBang (with some changes).
"The state, therefore, is the most flagrant, the most cynical, and the most complete negation of humanity." — Mikhail Bakunin

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 12143
Joined: Sun Dec 16, 2007 1:17 pm

Re: OpenBox Re-spin

#60

Post by dolphin_oracle » Mon May 13, 2019 3:49 pm

Head_on_a_Stick wrote:
Mon May 13, 2019 3:44 pm
dolphin_oracle wrote:
Mon May 13, 2019 3:31 pm
I have not had success starting policykit-1-gnome that way.
It works for BunsenLabs :happy:

The OP lifted the autostart file from that distribution and it was in turn inherited from CrunchBang (with some changes).
ok. the synaptic not starting was my main clue (synaptic uses synaptic-pkexec to start). the trash problem could be related (gvfs/thunar might use policykit, don't know, it wouldn't surprise me).

on the other hand, it might be worth exploring weather "menus" and/or "gksu" is installed and working.

to me it all sounds like a authentication and/or privledge escalation problem.
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-18.3
lenovo s21e - antiX-19 beta 2 (live-USB)
FYI: mx "test" repo is not the same thing as debian testing repo.

Post Reply

Return to “Community Submissions”